continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Engebakken Geir <>
Subject Authentication prtoblems in continuum, weird!
Date Thu, 15 Oct 2009 14:32:07 GMT
A follow up on this one which is quite peculiar. It really seems that settings.xml is used
for supplying credentials to 2 different accesses to a server.

The first one when continuum uploads a project by POM, which in our case need SVN credentials
which are LDAP.

The second when continuum kicks off maven with site:deploy, then it uses scp and needs credentials
for a unix user with write access to the maven-site  folder.

The same servername is used for both, actuallty same server as well, but different accesses.

The solution so far for us is to have the user created both in LDAP and Unix, and setting
the passwords identical, and give the correct accesses, but this seems really weird ? Any
one with a torch to lighten this up?

-----Original Message-----
From: Engebakken Geir [] 
Sent: 13. oktober 2009 11:50
Subject: RE: SOLVED : RE: Problem accessing maven pom in SVN from Continuum

Seems we might have a follow up error with this one.

The settings.xml contained the following definition :


We had to change the user/password here for the upload of the pom from (using
http GET, and LDAP authentication) to work. This seems now to have broken the site:deploy
as this tries to use the same user/password as authentication for scp upload to the same server,
but this scp authentication is plain unix authentication, and then the new LDAP user is not
authenticated correctly. Anyone has some deeper insight into what is going on here? 

-----Original Message-----
From: Engebakken Geir [] 
Sent: 12. oktober 2009 17:13
Subject: SOLVED : RE: Problem accessing maven pom in SVN from Continuum

Found the problem, but the solution was so weird that I would like to get some explanations
as to why this happens, or what is the idea behind this?

It seems that when uploading the pom from SVN, continuum uses a http GET, but fetches credentials
from its users (the userid running continuum, in our case root) .m2/settings.xml. It uses
the credentials it finds there for a servername identical to the server in the poms URL. These
were just some old wrong credentials at our place, so the fetching of the POM failed. Changing
to a correct subversion user made it all work. Incredible, or .......


-----Original Message-----
From: Engebakken Geir [] 
Sent: 12. oktober 2009 15:58
Subject: RE: Problem accessing maven pom in SVN from Continuum

We now just found out that the userid used by continuum,(by checvking the subversion logs)
in fact is the userid that owns the Subversion installation(?). So I wonder now how this user
id used to connect to subversion is found in continuum ....


-----Original Message-----
From: Engebakken Geir [] 
Sent: 8. oktober 2009 14:26
Subject: Problem accessing maven pom in SVN from Continuum

We try to add projects to continuum, by using the "POM URL" specification in "Add maven 2
project", but it fails with the following error :

You are not authorized to access the requested URL. Please verify that the correct username
and password are provided

I have tried to specify user/password for several users that definitely have access to the
Subversion repository, but it doesn't work.

In the log I see that continuum states the following :

2009-10-08 13:47:22,846 [addMavenTwoProjectBackgroundThread] ERROR continuumProjectBuilder#maven-two-builder
 - Error ad
ding project: Unauthorized http://z1416ge:********

(Password in clear text, but obscured in this mail)

I tried to use the command wget to get the specified URL, and that works fine. Any ideas of
what is happening here, somehow continuum doesn't get authorized in the SVN repos?


View raw message