continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Engebakken Geir <geir.engebak...@edb.com>
Subject RE: SOLVED : RE: Problem accessing maven pom in SVN from Continuum
Date Tue, 13 Oct 2009 09:50:07 GMT
Seems we might have a follow up error with this one.

The settings.xml contained the following definition :

        <server>
            <id>svn.edb.com</id>
            <username>csvn</username>
            <password>*****</password>
        </server>
    </servers>


We had to change the user/password here for the upload of the pom from svn.edb.com (using
http GET, and LDAP authentication) to work. This seems now to have broken the site:deploy
as this tries to use the same user/password as authentication for scp upload to the same server,
but this scp authentication is plain unix authentication, and then the new LDAP user is not
authenticated correctly. Anyone has some deeper insight into what is going on here? 



Geir
-----Original Message-----
From: Engebakken Geir [mailto:geir.engebakken@edb.com] 
Sent: 12. oktober 2009 17:13
To: users@continuum.apache.org
Subject: SOLVED : RE: Problem accessing maven pom in SVN from Continuum

Found the problem, but the solution was so weird that I would like to get some explanations
as to why this happens, or what is the idea behind this?

It seems that when uploading the pom from SVN, continuum uses a http GET, but fetches credentials
from its users (the userid running continuum, in our case root) .m2/settings.xml. It uses
the credentials it finds there for a servername identical to the server in the poms URL. These
were just some old wrong credentials at our place, so the fetching of the POM failed. Changing
to a correct subversion user made it all work. Incredible, or .......



Geir

-----Original Message-----
From: Engebakken Geir [mailto:geir.engebakken@edb.com] 
Sent: 12. oktober 2009 15:58
To: users@continuum.apache.org
Subject: RE: Problem accessing maven pom in SVN from Continuum

We now just found out that the userid used by continuum,(by checvking the subversion logs)
in fact is the userid that owns the Subversion installation(?). So I wonder now how this user
id used to connect to subversion is found in continuum ....


Geir

-----Original Message-----
From: Engebakken Geir [mailto:geir.engebakken@edb.com] 
Sent: 8. oktober 2009 14:26
To: users@continuum.apache.org
Subject: Problem accessing maven pom in SVN from Continuum

We try to add projects to continuum, by using the "POM URL" specification in "Add maven 2
project", but it fails with the following error :

You are not authorized to access the requested URL. Please verify that the correct username
and password are provided


I have tried to specify user/password for several users that definitely have access to the
Subversion repository, but it doesn't work.


In the log I see that continuum states the following :

2009-10-08 13:47:22,846 [addMavenTwoProjectBackgroundThread] ERROR continuumProjectBuilder#maven-two-builder
 - Error ad
ding project: Unauthorized http://z1416ge:********@svn.edb.com/repos/java/customer/scs/customer/admin/trunk/pom.xml

(Password in clear text, but obscured in this mail)


I tried to use the command wget to get the specified URL, and that works fine. Any ideas of
what is happening here, somehow continuum doesn't get authorized in the SVN repos?




Geir



Mime
View raw message