continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From declanru...@gmail.com
Subject problem with uploading artifact
Date Sat, 04 Apr 2009 10:24:24 GMT
Hi,

i'm trying to get contiuum to build and deploy a simple pom only project.  
It works via the cmd line (at the bottom) but fails via continuum as below.  
There is nothing obvious in the logs. The main difference is that the cmd  
line is the logged on windows user and continuum is running as a service.

any ideas?

Many thanks, Declan

2009-04-04 11:20:00,265 [pool-1-thread-2] INFO  
org.apache.maven.continuum.buildcontroller.DefaultBuildController -  
Performing action execute-builder
2009-04-04 11:20:00,281 [pool-1-thread-2] INFO  
org.apache.continuum.utils.shell.DefaultShellCommandHelper - Executing:  
cmd.exe /X /C "C:\enterprise\build\apache-maven-2.0.10\bin\mvn --batch-mode  
--non-recursive -Dcontinuum.project.lastBuild.state=3  
-Dcontinuum.project.nextBuild.number=7 "-Dcontinuum.project.name=Test  
Master POM" -Dcontinuum.project.id=6  
-Dcontinuum.project.version=1.0.0-SNAPSHOT  
-Dcontinuum.project.group.name=test -Dcontinuum.project.lastBuild.number=6  
-Dmaven.repo.local=C:\.m2\repository clean deploy"
2009-04-04 11:20:00,281 [pool-1-thread-2] INFO  
org.apache.continuum.utils.shell.DefaultShellCommandHelper - Working  
directory:  
C:\enterprise\build\apache-continuum-1.3.1\data\working-directory\6
2009-04-04 11:20:02,855 [pool-1-thread-2] INFO  
org.apache.maven.continuum.execution.maven.m2.MavenTwoBuildExecutor - Exit  
code: 1
2009-04-04 11:20:02,870 [pool-1-thread-2] INFO  
org.apache.maven.continuum.buildcontroller.DefaultBuildController -  
Performing action deploy-artifact


[INFO] Scanning for projects...
[INFO]  
------------------------------------------------------------------------
[INFO] Building Test Master POM
[INFO] task-segment: [clean, deploy]
[INFO]  
------------------------------------------------------------------------
[INFO] [clean:clean]
[INFO] [site:attach-descriptor]
[INFO] [install:install]
[INFO] Installing  
C:\enterprise\build\apache-continuum-1.3.1\data\working-directory\6\pom.xml  
to  
C:\.m2\repository\org\test\master\1.0.0-SNAPSHOT\master-1.0.0-SNAPSHOT.pom
[INFO] [deploy:deploy]
altDeploymentRepository = null
[INFO] Retrieving previous build number from test-snapshots
Uploading:  
http://localhost:8081/nexus/content/repositories/test-snapshots/org/test/master/1.0.0-SNAPSHOT/master-1.0.0-20090404.100422-2.pom
3K uploaded
[INFO]  
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]  
------------------------------------------------------------------------
[INFO] Error deploying artifact: Error creating temporary file for  
deployment: The system cannot find the path specified

[INFO]  
------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO]  
------------------------------------------------------------------------
[INFO] Total time: 2 seconds
[INFO] Finished at: Sat Apr 04 11:04:22 BST 2009
[INFO] Final Memory: 16M/29M
[INFO] ----------

there is no problem with the mvn cmd line deploy

+ Error stacktraces are turned on.
[INFO] Scanning for projects...
[INFO]  
------------------------------------------------------------------------
[INFO] Building Test Master POM
[INFO] task-segment: [clean, deploy]
[INFO]  
------------------------------------------------------------------------
[INFO] [clean:clean]
[INFO] [site:attach-descriptor]
[INFO] [install:install]
[INFO] Installing C:\enterprise\workspace\master\pom.xml to  
C:\Users\Administrator\.m2\repository\org\test\master\1.0.0-SNAPSHOT\master-1.0.0-SNAPSHOT.pom
[INFO] [deploy:deploy]
altDeploymentRepository = null
[INFO] Retrieving previous build number from test-snapshots
[INFO] repository metadata for: 'snapshot org.test:master:1.0.0-SNAPSHOT'  
could not be found on repository: test-snapshots, so will be created
Uploading:  
http://localhost:8081/nexus/content/repositories/test-snapshots/org/test/master/1.0.0-SNAPSHOT/master-1.0.0-20090404.094932-1.pom
3K uploaded
[INFO] Retrieving previous metadata from test-snapshots
[INFO] repository metadata for: 'artifact org.test:master' could not be  
found on repository: test-snapshots, so will be created
[INFO] Uploading repository metadata for: 'artifact org.test:master'
[INFO] Retrieving previous metadata from test-snapshots
[INFO] repository metadata for: 'snapshot org.test:master:1.0.0-SNAPSHOT'  
could not be found on repository: test-snapshots, so will be created
[INFO] Uploading repository metadata for: 'snapshot  
org.test:master:1.0.0-SNAPSHOT'
[INFO]  
------------------------------------------------------------------------

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message