continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Schulte ...@schulte.it>
Subject Re: Group build definition not executed when there is a project build definition ?
Date Mon, 09 Feb 2009 18:22:37 GMT
Wendy Smoak schrieb:
> On Mon, Feb 9, 2009 at 10:47 AM, Christian Schulte <cs@schulte.it> wrote:
> 
>> I added a multi-module project to continuum and have a build definition
>> at group level like 'clean deploy'. I would like continuum to execute an
>> additional build definition only for the parent project like 'clean
>> site-deploy'.
> ...
>> How can I configure the build-definitions to be executed both ?
> 
> What version of Continuum?  There was an issue with the first build
> "consuming" the changes, so that subsequent builds wouldn't execute.
> Not sure when/if it was resolved, but it should be in JIRA.
> 
> As a workaround, you could enable the 'Always Build' checkbox on that
> build def to get the site published regularly.
> 

This is with continuum-1.2.3. I just added the group build definition to
the parent project to see if that makes continnum execute both
definitions when both declared at project level. Have to wait until the
next schedule now. Will try 'Always Build', if that does not work.

Btw, continuum is backed by a postgres database here. Will the JDO
implementation correctly migrate the database automatically when
upgrading to 1.3 ? Something like downloading 1.3, setting up the
database connection to point to the same database currently in use by
1.2.3 and let continuum 1.3 migrate the database automatically during
startup ?

-- 
Christian


Mime
View raw message