continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From teacup <thedudea...@yahoo.com>
Subject Re: Multiple modules project and Continuum 1.2.2
Date Thu, 18 Dec 2008 14:40:10 GMT

It worked now.  This is what I did:

I added back only <snapshotRepository> tag (mentioned in my original post)
and then used the goal 'clean install deploy'.  Now Continuum deployed
artifacts for parent and all 3 children in the specified deployment
directory.

But I would still like to know if this is the only way to deploy children
artifacts through Continuum.  Thanks.


teacup wrote:
> 
> First off I made a mistake in my original post (thanks Wendy): when I said
> I checked the button, I meant the 'For multi modules project, load only
> root as recursive build' button and also I did not load POM from my PC but
> specified POM URL (with user name and password).  And, yes, I clicked that
> button 'For multi modules ...'.  Still I get only parent artifact
> deployed; the children artifacts still do not make it to the deployment
> directory.
> 
> Then I tried the same thing after removing <repository> and
> <snapshotRepository> tags from all POMs because 'Better Build with Maven'
> book says I do not need these tags if I want Continuum to deploy the
> snapshot artifacts.  But this does not work either.
> 
> Has anyone got children artifacts deployed through Continuum by adding
> only parent Maven 2.0 project? Would I need to add 'deploy' to the goal? 
> I am using only 'clean install' because I thought Continuum would deploy
> it for me through its default config for 'Deployment Repository
> Directory'.  Thanks.
> 
> 
> apache.maillist wrote:
>> 
>> Did you check the check box "For multi modules project, load only root as
>> recursive build"?
>> 
>> On Wed, Dec 17, 2008 at 12:47 PM, teacup <m_asifalvi@yahoo.com> wrote:
>> 
>>>
>>> Hello, all:
>>>
>>> I am using Continuum 1.2.2 and I have a multi-module project, with a
>>> parent
>>> POM and 3 children POM.  When I upload parent POM as Maven 2.0 project
>>> and
>>> click the 'Enter the local filename of the Maven 2 POM to upload (works
>>> only
>>> for a single project without modules)' button, all loads up fine. When I
>>> build this project recursively, everything (including site generation)
>>> works
>>> fine too, except that Continuum deploys only the parent artifact in the
>>> specified snapshots repository and none of the children artifacts make
>>> it
>>> to
>>> this repository.  Here is the code from distributionManagement part that
>>> I
>>> specify in all POM files:
>>>
>>> <repository>
>>>   <uniqueVersion>false</uniqueVersion>
>>>   <id>internal</id>
>>>   <name>Archiva Managed Internal Repository</name>
>>>
>>> <url>scp://specialuser@server
>>> :/opt/apache-tomcat-6.0.14/data/repositories/internal/</url>
>>>   <layout>default</layout>
>>> </repository>
>>>
>>> <snapshotRepository>
>>>   <uniqueVersion>true</uniqueVersion>
>>>   <id>snapshots</id>
>>>   <name>Archiva Managed Snapshot Repository</name>
>>>
>>> <url>scp://specialuser@server
>>> :/opt/apache-tomcat-6.0.14/data/repositories/snapshots/</url>
>>> </snapshotRepository>
>>>
>>> On Continuum Admin GUI, there is a 'Configuration' button that lets you
>>> specify a 'Deployment Repository Directory' - there too I have the same
>>> snapshots directory specified like this:
>>> /opt/apache-tomcat-6.0.14/data/repositories/snapshots
>>>
>>> But nothing works, and I still cannot get Continuum deploy children
>>> artifacts under above directory.  Would I need to upload and build all 4
>>> (1
>>> parent and 3 children) POMs individually to get around this issue, or I
>>> am
>>> missing something in the above setup?  Any help will be much
>>> appreciated.
>>> Thanks.
>>> --
>>> View this message in context:
>>> http://www.nabble.com/Multiple-modules-project-and-Continuum-1.2.2-tp21060827p21060827.html
>>> Sent from the Continuum - Users mailing list archive at Nabble.com.
>>>
>>>
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Multiple-modules-project-and-Continuum-1.2.2-tp21060827p21074027.html
Sent from the Continuum - Users mailing list archive at Nabble.com.


Mime
View raw message