continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "murali mohan" <muralih...@gmail.com>
Subject Re: Build Error
Date Tue, 21 Oct 2008 07:12:11 GMT
The pom file should be in  the svn root folder for a project. So when you
run a build, continuum will check out the whole project including the pom
file into the workcopy folder. All builds are run against the source code
checked out in the work copy folder. So the maven expects a Pom file there.
This is a maven problem rather than a continuum problem.

Murali.

On Tue, Oct 21, 2008 at 8:05 AM, Jan K <janokb@symbiountech.com> wrote:

>
> Hi snicoll,
>
> I am extremely new to continuum.I can say i am in a learning phase.i will
> say how my directory structure is :
>
> home/jan
>   -- continuum folder
>        ----- workcopy folder
>        ----- BuildCopy folder
>        ------ pom.xml
>
> This pom.xml file only i am using to upload in continuum.So inside
> continuum
> i have 2 folders and a pom file.Also can you be little more clear with what
> should i do?
>
> snicoll wrote:
> >
> > Do you use perforce by any chance?
> >
> > It happens when the pom.xml could not be resolved (because of a missing
> > dependency for instance). In that case, the pom.xml gets deleted for an
> > unknown reason. Since perforce has a hard link with the server, it does
> > not
> > realize that the file is not there anymore.
> > S.
> >
> > On Tue, Oct 21, 2008 at 8:41 AM, Brett Porter <brett@apache.org> wrote:
> >
> >> The directory that you checked out does not contain a pom.xml. If this
> is
> >> a
> >> Maven project, you need to checkout the location of the pom.xml.
> >>
> >> - Brett
> >>
> >> On 21/10/2008, at 5:38 PM, Jan K wrote:
> >>
> >>
> >>> I am getting a build error when i build my project in continuum.The
> >>> error
> >>> is
> >>>
> >>> [INFO] Scanning for projects...
> >>> [INFO]
> >>>
> ------------------------------------------------------------------------
> >>> [INFO] Building Maven Default Project
> >>> [INFO]    task-segment: [clean, install]
> >>> [INFO]
> >>>
> ------------------------------------------------------------------------
> >>> [INFO]
> >>>
> ------------------------------------------------------------------------
> >>> [ERROR] BUILD ERROR
> >>> [INFO]
> >>>
> ------------------------------------------------------------------------
> >>> [INFO] Cannot execute mojo: clean. It requires a project with an
> >>> existing
> >>> pom.xml, but the build is not using one.
> >>> [INFO]
> >>>
> ------------------------------------------------------------------------
> >>> [INFO] For more information, run Maven with the -e switch
> >>> [INFO]
> >>>
> ------------------------------------------------------------------------
> >>> [INFO] Total time: &lt; 1 second
> >>> [INFO] Finished at: Tue Oct 21 12:02:48 GMT+05:30 2008
> >>> [INFO] Final Memory: 1M/3M
> >>> [INFO] ------------------------------------------
> >>>
> >>> Please let me know how to fix this issue.
> >>> --
> >>> View this message in context:
> >>> http://www.nabble.com/Build-Error-tp20084286p20084286.html
> >>> Sent from the Continuum - Users mailing list archive at Nabble.com.
> >>>
> >>>
> >> --
> >> Brett Porter
> >> brett@apache.org
> >> http://blogs.exist.com/bporter/
> >>
> >>
> >
> >
> > --
> > Large Systems Suck: This rule is 100% transitive. If you build one, you
> > suck" -- S.Yegge
> >
> >
>
> --
> View this message in context:
> http://www.nabble.com/Build-Error-tp20084286p20084624.html
> Sent from the Continuum - Users mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message