continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan K <jan...@symbiountech.com>
Subject Re: Class file not generated on build?
Date Thu, 23 Oct 2008 05:10:52 GMT

Please give me any hints or help me to find out.I really donot know why i am
unable to create the class files.I can do it manually using my console.But
through continuum, i am getting my class files generated.any help is greatly
appreciated.

Jan K wrote:
> 
> I have a folder structure in svn as 
>   Training  -- This is my root folder
>   pom.xml
>   Inside Training Folder ,i have
>     -- Branch
>    --  Tag
>    -- Trunk
>   Inside Trunk folder,i have
>    Test.Java
> 
>  When i build using Continuum, i get a folder structure created as
>    MyProject/workingCopy/21/target. But inside this target folder  i can
> see only maven-archiver folder and a careertales-1.0-SNAPSHOT.jar 
> I dont see any classes folder.But if i compile from my console, i can get
> classes folder with the class file.Then what is wrong with it?
> Here is my pom.xml
> 
> <project xmlns="http://maven.apache.org/POM/4.0.0"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>   xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
> http://maven.apache.org/maven-v4_0_0.xsd">
>   <modelVersion>4.0.0</modelVersion>
>   <groupId>com.careertales</groupId>
>   <artifactId>careertales</artifactId>
>   <packaging>jar</packaging>
>   <version>1.0-SNAPSHOT</version>
>   <name>CT</name>
>   
> 
>   <scm>
>     <connection>scm:svn:http://svn.saka.int/test/</connection>
>    
> <developerConnection>scm:svn:http://svn.saka.int/test/</developerConnection>
> </scm>
> <developers>
>   <developer>
>     <id>Jan</id>
>     <name>Jan</name>
>     jan@symb.com
>      </developer>
>  <developer>
>     <id>Ram</id>
>     <name>Ram</name>
>     rsad@symb.com
>     </developer>
>  
> </developers>
> 
> <ciManagement>
> <system>continuum</system>
> <url>http://localhost:8080/continuum</url>
> <notifiers>
>     <notifier>
>       <type>mail</type>
>       <configuration>
>         <address>Jan</address>
>  	<sendOnError>true</sendOnError>
>         <sendOnFailure>true</sendOnFailure>
>         <sendOnSuccess>true</sendOnSuccess>
>         <sendOnWarning>false</sendOnWarning>
>       </configuration>
>     </notifier>
>     
> </notifiers>
> </ciManagement>
> 
>  </project>
> 
> Please let me know how to fix this issue.
> 
> 
>  
> 
> Wendy Smoak-3 wrote:
>> 
>> On Tue, Oct 21, 2008 at 7:00 AM, Jan K <janokb@symbiountech.com> wrote:
>> 
>>> I am able to build successfully.But i donot see any class files
>>> created?why
>>> it is so.
>> 
>> Where are you looking for the class files?  Does building the same
>> project from the command line do what you expect?
>> 
>> If your project is building a jar file, you should see the jar and
>> classes under 'target' in the working directory, which you can view
>> through the Continuum web UI.
>> 
>>> Also i have
>>> specified notifiers .It seems the mail is not sending to the
>>> corresponding
>>> person.I have configured the mail part in application.xml but still it
>>> is
>>> not working.
>> 
>> What did you change in application.xml?  Did you do anything else?
>> 
>> Mail notifiers can be configured in the pom.xml for the project, or
>> through the Continuum web interface.
>> http://continuum.apache.org/docs/1.2/user_guides/notification/mail.html
>> 
>> (It's best to ask unrelated questions in separate threads with
>> descriptive subject lines, so that people interested in and
>> knowledgeable about different topics can find them easily.)
>> 
>> -- 
>> Wendy
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Class-file-not-generated-on-build--tp20090919p20124486.html
Sent from the Continuum - Users mailing list archive at Nabble.com.


Mime
View raw message