continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From KURT TOMETICH <boomtow...@msn.com>
Subject RE: AW: Problem retrieving content from SVN on Windows XP
Date Mon, 22 Sep 2008 17:24:53 GMT

You should still be able to run it as a service, but if running it manually works for you
then I would stick with it.  I had a similar problem when setting up Continuum, but as soon
as I changed the service to run as the user I could run the program with manually, I was able
to get the service to work.  It sounded like you had already changed the logon user of the
service though ... correct?  If so make sure that's the user you are actually logged in as
when you can get it to run manually.  As long as you are using the same user as you are when
you run manually (when it works) it should run with the same path.

Kurt



> Date: Mon, 22 Sep 2008 09:50:48 -0700
> From: thomas.revesz@xeq.se
> To: users@continuum.apache.org
> Subject: Re: AW: Problem retrieving content from SVN on Windows XP
> 
> 
> I disabled the service and started Continuum manually instead. Now it works
> like a charm. Thanks a lot for your help!
> 
> /Tom
> 
> 
> 
> Marc L wrote:
> > 
> > are you really sure that SVN is in the system path of the user who has
> > started Continuum?
> > If you start Continuum as a windows service, you will run into trouble.
> > 
> > 
> > -----Urspr√ľngliche Nachricht-----
> > Von: ThomasRe [mailto:thomas.revesz@xeq.se] 
> > Gesendet: Montag, 22. September 2008 15:48
> > An: users@continuum.apache.org
> > Betreff: Problem retrieving content from SVN on Windows XP
> > 
> > 
> > Hello all,
> > 
> > Continuum 1.1 fails to retrieve the content from SVN prior to building.
> > The
> > error message I get is "Command output: 'svn' is not recognized as an
> > internal or external command, operable program or batch file." However,
> > SVN
> > is set up in the system path and otherwise perfectly accessible so I
> > suspect
> > that the Continuum-generated command string is really the culprit here:
> > 
> > cmd.exe /X /C '"svn --username tommy --password ***** --non-interactive
> > checkout http://server/svn/MyProj/branches/0.1 1"'
> > 
> > I suspect it is faulty because of the single + double quotes ('") that
> > surround the svn command. I have tested the command stand-alone from a cmd
> > prompt and it works fine if I use just double quotes (") around the
> > string.
> > However, using the string as it appears in the log i.e., with single +
> > double quotes, does not work. Windows XP then complains that "The
> > filename,
> > directory name, or volume label syntax is incorrect." 
> > 
> > However, since Windows XP is not that unusual, I would be surprised if I
> > am
> > the only one who has encountered this so maybe something else is really
> > the
> > problem? I have seen others with the 'svn not recognized' error message
> > but
> > in those cases it seems more like problems with the SVN path.
> > 
> > I am running Continuum as a service, logged on as a local user with admin
> > rights.
> > 
> > Any help on how to resolve or circumvent this problem would be much
> > appreciated!
> > 
> > Thanks!
> > Tom
> > 
> > 
> > Log snippet:
> > 
> > 9446843 [pool-1-thread-1] INFO 
> > org.apache.maven.continuum.scm.ContinuumScm:default  - Checking out
> > project:
> > 'webkonto', id: '1' to 'C:\Program
> > Files\Apache\continuum-1.1\apps\continuum\webapp\WEB-INF\working-directory\1'
> > with branch/tag branches/0.1.
> > 9447406 [pool-1-thread-1] INFO 
> > org.apache.maven.scm.manager.ScmManager:default  - Executing: cmd.exe /X
> > /C
> > '"svn --username tommy --password ***** --non-interactive checkout
> > http://server/svn/MyProj/branches/0.1 1"'
> > 9447406 [pool-1-thread-1] INFO 
> > org.apache.maven.scm.manager.ScmManager:default  - Working directory:
> > C:\Program
> > Files\Apache\continuum-1.1\apps\continuum\webapp\WEB-INF\working-directory
> > 9447593 [pool-1-thread-1] WARN 
> > org.apache.maven.continuum.scm.ContinuumScm:default  - Error while
> > checking
> > out the code for project: 'webkonto', id: '1' to 'C:\Program
> > Files\Apache\continuum-1.1\apps\continuum\webapp\WEB-INF\working-directory\1'
> > with branch/tag branches/0.1.
> > 9447593 [pool-1-thread-1] WARN 
> > org.apache.maven.continuum.scm.ContinuumScm:default  - Command output:
> > 'svn'
> > is not recognized as an internal or external command,
> > operable program or batch file.
> > 
> > 
> > -- 
> > View this message in context:
> > http://www.nabble.com/Problem-retrieving-content-from-SVN-on-Windows-XP-tp19608325p19608325.html
> > Sent from the Continuum - Users mailing list archive at Nabble.com.
> > 
> > 
> > 
> 
> -- 
> View this message in context: http://www.nabble.com/Problem-retrieving-content-from-SVN-on-Windows-XP-tp19608325p19612045.html
> Sent from the Continuum - Users mailing list archive at Nabble.com.
> 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message