continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From smitherz <riverofc...@gmail.com>
Subject Re: Build ordering suddenly changed.
Date Tue, 09 Sep 2008 02:20:31 GMT

I just looked at a couple of the projects and their configurations. All the
projects seem to have their dependencies
listed as they should. It looks like I may be clobbering my installation or
at least downing the one I have running
and doing a "clean" install next to it then reloading my projects from
scratch. Not fun.

Scott


Brett Porter wrote:
> 
> To my knowledge this level of detail is not shown. Perhaps your dependency
> table was corrupted - you didn't mention whether the projects still listed
> dependencies in their info pages?
> With a release coming out very shortly that it might be worth trying.
> 
> Cheers,
> Brett
> 
> 2008/9/8 smitherz <riverofcode@gmail.com>
> 
>>
>> Hi,
>>
>> I just checked my scheduled builds and they ran in alphabetical order. I
>> have to get this straightened out soon. We have a release scheduled for
>> this
>> weekend. At the moment I am going to have to "schedule" them manually.
>>
>> Any thoughts as to how I can get continuum to spit out its queue sorting
>> results just before it queues jobs? I am about to blow away the install
>> and
>> rebuild it clean if I thought it would fix it. I don't have any real
>> users
>> defined and just the 25 projects that are critical to be built here.
>>
>> Scott
>>
>>
>> Brett Porter wrote:
>> >
>> > Did this resolve itself?
>> > One thing to check the difference of is the dependency elements in
>> > individual projects still exist.
>> >
>> > Cheers,
>> > Brett
>> >
>> > 2008/9/6 smitherz <riverofcode@gmail.com>
>> >
>> >>
>> >> Hi all,
>> >>
>> >> I am running version 1.1 for quite some time and have not had any
>> >> significant issues with it. However today I logged into
>> >> my instance and browsed to a project group and hit "build all project"
>> >> button. When I usually do that it only builds the
>> >> projects in the group I am looking at. Today it did all projects
>> defined
>> >> in
>> >> continuum.
>> >>
>> >> That was not the biggest issue though... it queued them up in
>> >> alphabetical
>> >> order and not in the proper build order that it
>> >> normally does. This of course was bad news. I resorted to firing up an
>> >> old
>> >> 1.03 instance on a windows box and launching
>> >> a build there to get the sort order. Then manually queued them in the
>> >> proper
>> >> order. This group has 25 projects in it.
>> >> The last generates an ear of the others.
>> >>
>> >> Thoughts on what is happening?  I tried de-queueing then stopping and
>> >> restarting the instance but that didn't help. I have a
>> >> scheduled run that starts at 23:00 eastern/US and I will have to see
>> what
>> >> order it gets run in.
>> >>
>> >> Scott
>> >>
>> >> --
>> >> View this message in context:
>> >>
>> http://www.nabble.com/Build-ordering-suddenly-changed.-tp19342446p19342446.html
>> >> Sent from the Continuum - Users mailing list archive at Nabble.com.
>> >>
>> >>
>> >
>> >
>> > --
>> > Brett Porter
>> > Blog: http://blogs.exist.com/bporter/
>> >
>> >
>>
>> --
>> View this message in context:
>> http://www.nabble.com/Build-ordering-suddenly-changed.-tp19342446p19371174.html
>> Sent from the Continuum - Users mailing list archive at Nabble.com.
>>
>>
> 
> 
> -- 
> Brett Porter
> Blog: http://blogs.exist.com/bporter/
> 
> 

-- 
View this message in context: http://www.nabble.com/Build-ordering-suddenly-changed.-tp19342446p19384827.html
Sent from the Continuum - Users mailing list archive at Nabble.com.


Mime
View raw message