continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Morgovsky, Alexander (US - Glen Mills)" <amorgov...@deloitte.com>
Subject RE: data-management-cli-1.1-app throws NullPointerException in downloadArtifact
Date Mon, 11 Aug 2008 20:51:32 GMT
It is possible to have continuum use only maven/conf/settings.xml and
not ~/.m2/settings.xml?

-----Original Message-----
From: Olivier Lamy [mailto:olamy@apache.org] 
Sent: Monday, August 11, 2008 4:45 PM
To: users@continuum.apache.org
Subject: Re: data-management-cli-1.1-app throws NullPointerException in
downloadArtifact

Hi,
Do you have any profiles declared in your ~/.m2/settings.xml ?

--
Olivier

2008/8/11 simon <skitching@apache.org>:
> Hi,
>
> I'm trying to do an upgrade of an existing continuum installation (for
> apache myfaces). This is solaris on x86 with java 1.5.0_16. The old
> version is 1.1-beta-2, the new version is 1.1 (final release).
>
> I've successfully exported the data from the old version (after
shutting
> it down).
>
> I've also installed and started the new version, then stopped it
again.
>
> But when I try to import data into the new instance I get a very weird
> error:
>
> -bash-3.00$ java -Xmx512m -jar data-management-cli-1.1-app.jar
> -usersJdbcUrl jdbc:derby:/local/continuum-1.1/data/users/database
-mode
> IMPORT -directory backups -debug
>
> 0 [main] INFO org.apache.maven.continuum.management.DataManagementCli
-
> Processing Redback database...
> Exception in thread "main" java.lang.NullPointerException
>        at
>
org.apache.maven.continuum.management.DataManagementCli.downloadArtifact
(DataManagementCli.java:364)
>        at
>
org.apache.maven.continuum.management.DataManagementCli.processDatabase(
DataManagementCli.java:198)
>        at
>
org.apache.maven.continuum.management.DataManagementCli.main(DataManagem
entCli.java:177)
>
> Using -debug flag gives no extra info.
>
> Can someone suggest what might be the problem? The maven stuff seems
to
> be ok; I can run "mvn help:effective-pom" and "mvn
help:active-profiles"
> and get what I expect (including a mapping to the Sun maven repo for
the
> j2ee jars that this app seems to need).
>
> Testing trivial export/import from fresh continuum installation on my
> personal PC works fine. So it's either a problem with the exported
data
> somehow, or a problem with the environment. The error message seems to
> indicate a problem with maven or maven repo setup, but I don't have
any
> idea what it could be...
>
>
> Some other notes:
> *  The instructions here don't quite work for me
>  http://continuum.apache.org/docs/1.1/installation/upgrade.html
>
> Exporting the builds data goes fine. But then when exporting the user
> data, an error message about "directory already exists" is shown.
Trying
> to use a different dir for user export data gives an error message
about
> "keys missing". Specifying the same output dir as for builds data,
plus
> "-overwrite" does work.
>
> Is using "-overwrite" the correct thing to do? If so, then updating
the
> installation instructions would be really helpful.
>
> What if I want to export just user data - how can that be done?
>
> * Needing to download sun jars when the management app was started
feels
> rather odd to me. Adding the sun maven repo to my settings.xml solves
> it. However if it is possible to avoid this in future, that might be
> nice.
>
>
> Thanks in advance,
> Simon
>
>
>

Mime
View raw message