continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Venisse" <emmanuel.veni...@gmail.com>
Subject Re: Double builds - defect CONTINUUM-1747
Date Wed, 18 Jun 2008 16:37:48 GMT
Do you have added your parent project in Continuum?
Do you have added the parent project in a remote repository?
Do you have define scm url in your projects or only in the parent?

Emmanuel

On Wed, Jun 18, 2008 at 3:39 PM, JAIGU Yann <yjaigu@effigie.fr> wrote:

> Hi all,
>
> We're using continuum 1.1 with Maven 2.0.9 on a Windows 2003 Server box
> since january.
> Since 2 weeks, we have the problem described in the following defect:
> http://jira.codehaus.org/browse/CONTINUUM-1747.
> It never happened before.
>
> The first build fails with the following stacktrace:
> org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Error
> executing action 'update-project-from-working-directory'
>        at
> org.apache.maven.continuum.buildcontroller.DefaultBuildController.perfor
> mAction(DefaultBuildController.java:434)
>        at
> org.apache.maven.continuum.buildcontroller.DefaultBuildController.build(
> DefaultBuildController.java:139)
>        at
> org.apache.maven.continuum.buildcontroller.BuildProjectTaskExecutor.exec
> uteTask(BuildProjectTaskExecutor.java:50)
>        at
> org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$Execut
> orRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
>        at
> edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter
> .call(Executors.java:442)
>        at
> edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask
> .java:176)
>        at
> edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker
> .runTask(ThreadPoolExecutor.java:665)
>        at
> edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker
> .run(ThreadPoolExecutor.java:690)
>        at java.lang.Thread.run(Thread.java:595)
> Caused by:
> org.apache.maven.continuum.execution.ContinuumBuildExecutorException:
> Error while mapping metadata:add.project.artifact.not.found.error
> add.project.unknown.error
>
>        at
> org.apache.maven.continuum.execution.maven.m2.MavenTwoBuildExecutor.upda
> teProjectFromCheckOut(MavenTwoBuildExecutor.java:157)
>        at
> org.apache.maven.continuum.core.action.UpdateProjectFromWorkingDirectory
> ContinuumAction.execute(UpdateProjectFromWorkingDirectoryContinuumAction
> .java:75)
>        at
> org.apache.maven.continuum.buildcontroller.DefaultBuildController.perfor
> mAction(DefaultBuildController.java:408)
>        ... 8 more
>
> The second build works as usual.
>
>
> This problem occurs for every builds since I added a parent POM to all
> existing projects.
> Additionnaly, when continuum builds a project, its version number is not
> correctly fetched and the previous one is displayed instead.
>
>
> Is there a known workaround to these 2 bugs?
> Is there a way to enable debug output, in order to find the original
> problem?
>
> Thanks in advance.
>
> Yann
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message