continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <bjorn.de.bak...@accenture.com>
Subject RE: Accessing network drive with Continuum and notifiers
Date Tue, 13 May 2008 08:48:37 GMT
Thanks Jon for the information.  

Björn De Bakker 


-----Original Message-----
From: SlinnHawkins, Jon (ELS-CAM) [mailto:J.SlinnHawkins@elsevier.com] 
Sent: dinsdag 13 mei 2008 9:44
To: users@continuum.apache.org
Subject: RE: Accessing network drive with Continuum and notifiers

Hi Bjorn, 

1/ This is a windows service issue again.  Windows services have no knowledge of any mapped
network drives.  

2/ Continuum will only send you an email when the state changes.  Ie. A previously failing
build is now successful.  You can force Continuum to always send an email by setting the (META_INF/Plexus/application.xml)
configuration property <alwaysSend>false</alwaysSend> to true.  

Cheers

Jon

-----Original Message-----
From: bjorn.de.bakker@accenture.com [mailto:bjorn.de.bakker@accenture.com] 
Sent: 13 May 2008 07:32
To: users@continuum.apache.org
Subject: Accessing network drive with Continuum and notifiers

I don't know if this is a Continuüm issue or more an Ant problem, but I'll try it overhere.
  We have a Continuum running and it works fine.  What we want to establish is that when a
build is successful, it has to copy the build to a shared network drive.  Continuum runs as
a Windows service and the copying is done through an ant task, which is configured in a pom-file.
 For some reason, Continuum can't access that shared drive.  It's mapped in Windows and when
we log in with the user, we can access that drive with Explorer.  

 

Does anyone know why this fails?  It's an annoying problem, because now we copy everything
to a folder and then copy it with a bat-file (scheduled task in Windows).

 

Second problem: notifying people of the build results.

 

We have a multi-module project which is handled by Continuum.  I've configured Continuum so
that it builds automatically at midnight, every day.  For some reason Continuum doesn't send
an e-mail of the build status.  I've configured the notifiers, so that it sends an e-mail
on each status (success, warning, failure).  Is it because source code hasn't changed, that
Continuum doesn't send e-mails?  Because it sometimes works, but sometimes it doesn't.



This message is for the designated recipient only and may contain privileged, proprietary,
or otherwise private information.  If you have received it in error, please notify the sender
immediately and delete the original.  Any other use of the email by you is prohibited.


This email is from Elsevier Limited, a company registered in England and Wales with company
number 1982084,
whose registered office is The Boulevard, Langford Lane, Kidlington, Oxford, OX5 1GB, United
Kingdom.





This message is for the designated recipient only and may contain privileged, proprietary,
or otherwise private information.  If you have received it in error, please notify the sender
immediately and delete the original.  Any other use of the email by you is prohibited.

Mime
View raw message