continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Dehon <odn...@gmail.com>
Subject Re: multi module project
Date Wed, 23 Apr 2008 01:09:34 GMT
I have noticed this behavior also in continuum 1.1 that if there is a
POM validation error (either a syntax error or non compliance to the
model), continuum reports that it cannot find the maven-clean-plugin.

If I check the project out and try a manual "mvn clean install", maven
reports the xml error properly.

When I fix the error and check the pom back in, continuum is now able to
build the projects correctly.

-Olivier

On Tue, 2008-04-22 at 14:19 +0200, bjorn.de.bakker@accenture.com wrote:
> Dear all
> 
> We have a project that consists out of multiple sub projects.  They're all configured
in the POM file and when I upload that pom file everything goes fine.  Continuum performs
a checkout of all the files.  But when I want to run a test build, I encounter a failure.
 That failure has 2 errors.  The first error is that I get "POM 'org.apache.maven.plugins:maven-clean-plugin'
not found in repository.".  Another error is "Can not find parent in any repository".  
> 
> Why is the application showing these errors?  I think that normal behavior is that it
checks in the local repository, before accessing the online repositories.  I've had that error
before, but that was because I installed a new version of Maven and I hadn't configured the
local repository yet.  That's not the case at this moment, so I really don't know what to
change or what's causing this problem.
> 
> Thanks in advance.
> 
> Kind regards,
> 
> Björn
> 
>  
> 
> 
> 
> This message is for the designated recipient only and may contain privileged, proprietary,
or otherwise private information.  If you have received it in error, please notify the sender
immediately and delete the original.  Any other use of the email by you is prohibited.


Mime
View raw message