continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Venisse" <emmanuel.veni...@gmail.com>
Subject Re: Problem with CVS
Date Tue, 22 Apr 2008 08:58:26 GMT
Maybe it is a pb with the full java cvs provider. You can use the native cvs
provider by adding a system property in the Continuum startup script :

-Dmaven.scm.provider.cvs.implementation=cvs_native

Emmanuel


On Thu, Apr 17, 2008 at 4:39 PM, Jeroen Verhagen <jeroenverhagen@gmail.com>
wrote:

> Hi all,
>
> I'm using Continuum to run a CVS project but for some reasosn unknown
> to me the build fails with the following error message:
>
> Provider message: The cvs command failed.
> Command output:
>
> -------------------------------------------------------------------------------
>
>
> -------------------------------------------------------------------------------
>
> In the logfiles (below) i see a problem with an Incorrect format for
> CVSRoot but i configured the scm url like this:
> scm:cvs:pserver:continuum:continuum@mposerv2
> :/home/cvsowner/cvs-server-root
> which is correct CVSROOT as far as i know (it works in Wincvs).
>
> Could anyone please tell me what might be the problem?
>
>
>
> INFO   | jvm 1    | 2008/04/17 16:16:08 | 2008-04-17 16:16:08,004
> [pool-1-thread-1] INFO
> org.apache.maven.continuum.scm.ContinuumScm:default  - Checking out
> project: 'mce', id: '1' to
> 'C:\java\continuum-1.1\apps\continuum\webapp\WEB-INF\working-directory\1'.
> INFO   | jvm 1    | 2008/04/17 16:16:08 | 2008-04-17 16:16:08,006
> [pool-1-thread-1] INFO
> org.apache.maven.scm.manager.ScmManager:default  - Executing: cmd.exe
> /X /C '"cvs -z3 -f -d :pserver:continuum@mposerv2 -q checkout -d 1
> /home/cvsowner/cvs-server-root"'
> INFO   | jvm 1    | 2008/04/17 16:16:08 | 2008-04-17 16:16:08,006
> [pool-1-thread-1] INFO
> org.apache.maven.scm.manager.ScmManager:default  - Working directory:
> C:\java\continuum-1.1\apps\continuum\webapp\WEB-INF\working-directory
> INFO   | jvm 1    | 2008/04/17 16:16:08 | 2008-04-17 16:16:08,006
> [pool-1-thread-1] ERROR
> org.apache.maven.scm.manager.ScmManager:default  - Incorrect format
> for CVSRoot: :pserver:continuum@mposerv2
> INFO   | jvm 1    | 2008/04/17 16:16:08 | The correct format is:
> [:method:][[user][:password]@][hostname:[port]]/path/to/repository
> INFO   | jvm 1    | 2008/04/17 16:16:08 | where "method" is pserver.
> INFO   | jvm 1    | 2008/04/17 16:16:08 | 2008-04-17 16:16:08,006
> [pool-1-thread-1] WARN
> org.apache.maven.continuum.scm.ContinuumScm:default  - Error while
> checking out the code for project: 'mce', id: '1' to
> 'C:\java\continuum-1.1\apps\continuum\webapp\WEB-INF\working-directory\1'.
> INFO   | jvm 1    | 2008/04/17 16:16:08 | 2008-04-17 16:16:08,006
> [pool-1-thread-1] WARN
> org.apache.maven.continuum.scm.ContinuumScm:default  - Command output:
> INFO   | jvm 1    | 2008/04/17 16:16:08 | 2008-04-17 16:16:08,006
> [pool-1-thread-1] WARN
> org.apache.maven.continuum.scm.ContinuumScm:default  - Provider
> message: The cvs command failed.
> INFO   | jvm 1    | 2008/04/17 16:16:08 | 2008-04-17 16:16:08,020
> [pool-1-thread-1] INFO
> org.apache.maven.continuum.buildcontroller.BuildController:default  -
> Merging SCM results
> INFO   | jvm 1    | 2008/04/17 16:16:08 | 2008-04-17 16:16:08,034
> [pool-1-thread-1] INFO
> org.apache.maven.continuum.buildcontroller.BuildController:default  -
> Error updating from SCM, not building
>
>
> --
>
> regards,
>
> Jeroen
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message