continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Venisse" <emmanuel.veni...@gmail.com>
Subject Re: can't send mail - using tomcat6, java6, and continuum1.1
Date Fri, 04 Apr 2008 09:51:51 GMT
On Fri, Apr 4, 2008 at 5:58 AM, Christopher Lyth <cjlyth@gmail.com> wrote:

> *I cant seem to get any emails to send. I have changed the "from address"
> in
> the application xml to be my gmail address. I'm not sure what to try next,
> I
> have tried multiple gmail accounts and my work SMTP server and I get the
> same stack trace.
> *
> <Context path="/continuum"
>         docBase="/usr/share/apache-tomcat-6.0.16/webapps/continuum">
>
>  <Resource name="jdbc/users"
>            auth="Container"
>            type="javax.sql.DataSource"
>            username="sa"
>            password=""
>            driverClassName="org.apache.derby.jdbc.EmbeddedDriver"
>            url="jdbc:derby:database/users;create=true" />
>
>  <Resource name="jdbc/continuum"
>            auth="Container"
>            type="javax.sql.DataSource"
>            username="sa"
>            password=""
>            driverClassName="org.apache.derby.jdbc.EmbeddedDriver"
>            url="jdbc:derby:database/continuum;create=true" />
>
>  <Resource name="mail/Session"
>            type="javax.mail.Session"
>            mail.smtp.host="smtp.gmail.com"
>            mail.smtp.port="465"
>            mail.debug="true"
>            mail.smtp.auth="true"
>            mail.smtp.user="my_email@gmail.com"
>            password="my_password"
>            mail.smtp.starttls.enable="true"
>            mail.smtp.socketFactory.class="javax.net.ssl.SSLSocketFactory"
>    />
> </Context>
>
> *And a snippet from the stack trace...*
>
> Caused by: javax.mail.AuthenticationFailedException
>        at javax.mail.Service.connect(Service.java:306)
>        at
>
> org.codehaus.plexus.mailsender.javamail.AbstractJavamailMailSender.send(AbstractJavamailMailSender.java:212)
>        ... 72 more
>

It's a basic answer but with this snippet, it seems you were connected to
the smtp host but the authentication failed. login/password was correct?
I think the password property name is 'mail.smtp.password' instead of
'password' in the mail/session resource definition

Emmanuel

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message