continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claudio Ranieri <claud...@buscape-inc.com>
Subject RES: Problem in Build Definitions
Date Mon, 28 Apr 2008 14:21:07 GMT
I want run only "my install" each 10 minutes. The "my deploy" is executed only when I want
a deploy application in my production enviroment.
The "my deploy" needs has a schedule. I used the same schedule of "my install".
Only one build definitons is automaticly executed by schedule (marked with default), correct?
Thanks

-----Mensagem original-----
De: Emmanuel Venisse [mailto:emmanuel.venisse@gmail.com]
Enviada em: segunda-feira, 28 de abril de 2008 11:09
Para: users@continuum.apache.org
Assunto: Re: Problem in Build Definitions

Why do you want to run "clean install" two times every 10 minutes?

On Mon, Apr 28, 2008 at 3:15 PM, Claudio Ranieri <claudior@buscape-inc.com>
wrote:

> Hi,
>
> Can someone help me?
> Thanks
>
> -----Mensagem original-----
> De: Claudio Ranieri [mailto:claudior@buscape-inc.com]
> Enviada em: quinta-feira, 24 de abril de 2008 16:44
> Para: users@continuum.apache.org
> Assunto: RES: Problem in Build Definitions
>
> Sorry, in better format
>
> My first build definition
> ----------------------------------------
> Goals: clean install
> Arguments: --batch-mode --non-recursive
> Build File: pom.xml
> Schedule: ten minutes
> Profile:
> From: GROUP
> Build Fresh: false
> Default: true
> Description: my install
> Type: maven2
>
> My second build definition
> ---------------------------------------
> Goals: clean install wagon:deploy
> Arguments: --batch-mode --non-recursive
> Build File: pom.xml
> Schedule: ten minutes
> Profile:
> From: PROJECT
> Build Fresh: false
> Default: false
> Description: my deploy
> Type: maven2
>
> The default build is "my install"(description), but the "my
> deploy"(description) is executed in schedule trigger. Why?
> Thanks
>
>
> -----Mensagem original-----
> De: Claudio Ranieri [mailto:claudior@buscape-inc.com]
> Enviada em: quinta-feira, 24 de abril de 2008 16:34
> Para: users@continuum.apache.org
> Assunto: Problem in Build Definitions
>
> Hi,
>
> I am using Continuum 1.1 final
> In my project, I have 2 build definitions:
>
> Goals                                           | Arguments
>                         | Build File  | Schedule      | Profile | From
>  | Build Fresh | Default  | Description   | Type
> clean install                               | --batch-mode --non-recursive
> | pom.xml | ten minutes |               | GROUP   | false              |
> true        | my install       | maven2
> clean install wagon:deploy | --batch-mode --non-recursive | pom.xml | ten
> minutes |               | PROJECT | false              | false       | my
> deploy     | maven2
>
> The default build is "my install", but the "my deploy" is executed in
> schedule trigger. Why?
> Thanks
>

Mime
View raw message