continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tonte Pouncil <etno...@yahoo.com>
Subject Re: Continuum1.1.war not recognizing Subversion command 'svn' -- Need help!
Date Fri, 14 Mar 2008 03:11:10 GMT
Ok, I was able to change my services to log on as the account I am logged on as and everything
worked out just fine after that.  So my problem is resolved thanks to Kurts and all the others
who took time out to see about little old me. 

Big Thanks!

Tonté



----- Original Message ----
From: Tonte Pouncil <etnot96@yahoo.com>
To: users@continuum.apache.org
Sent: Thursday, March 13, 2008 8:48:05 PM
Subject: Re: Continuum1.1.war not recognizing Subversion command 'svn' -- Need help!

Ok I see my tomcat is logged on as Local System.  Is there a way to set environment variables
for Local System?

Thanks!

----- Original Message ----
From: Tonte Pouncil <etnot96@yahoo.com>
To: users@continuum.apache.org
Sent: Thursday, March 13, 2008 8:29:47 PM
Subject: Re: Continuum1.1.war not recognizing Subversion command 'svn' -- Need help!

Ok, That makes sense.  I must say I don't know how to change tomcat to run as the same user
as I am logged in as.  Can you kindly guide me through this process?  

Thanks!

----- Original Message ----
From: KURT TOMETICH <boomtown15@msn.com>
To: users@continuum.apache.org
Sent: Thursday, March 13, 2008 5:18:39 PM
Subject: RE: Continuum1.1.war not recognizing Subversion command 'svn' -- Need help!


Tomcat is probably running as a service though... right?  My point being that the default
for services is to run as local system user and this account usually does not get the same
PATH set as the user you are currently testing SVN out with on the command line.  If tomcat
is being run as a service then I would change it to run as the same user as you are currently
logged in as.


> Subject: RE: Continuum1.1.war not recognizing Subversion command 'svn' -- Need help!
> To: users@continuum.apache.org
> From: Tonte.Pouncil@aviall.com
> Date: Thu, 13 Mar 2008 17:09:26 -0500
> 
> No I am running Continuum1.1.war as a web application on Tomcat6.0.14 on a
> Windows XP box.  I recenlty added SVN_HOME System variable too.
> 
> 
>                                                                            
>              KURT TOMETICH                                                
>              <boomtown15@msn.c                                            
>              om>                                                        To 
>                                        <users@continuum.apache.org>        
>              03/13/2008 04:59                                          cc 
>              PM                                                            
>                                                                    Subject 
>                                        RE: Continuum1.1.war not            
>              Please respond to        recognizing Subversion command      
>              users@continuum.a        'svn' -- Need help!                
>                  pache.org                                                
>                                                                            
>                                                                            
>                                                                            
>                                                                            
>                                                                            
> 
> 
> 
> 
> 
> Are you running Continuum as a Windows service?
> 
> 
> 
> > Subject: Re: Continuum1.1.war not recognizing Subversion command 'svn' --
> Need help!
> > To: users@continuum.apache.org
> > CC: claudior@buscape-inc.com; users@continuum.apache.org
> > From: Tonte.Pouncil@aviall.com
> > Date: Thu, 13 Mar 2008 16:39:52 -0500
> >
> > Is there any one out there that can help me out with this issue.  I have
> > search on the web and I see that I am not the only one with this problem.
> >
> > I wonder what would  keep Continuum from recognizing my svn command, when
> I
> > can verify it works from the cmd line?
> >
> >
> >
> 
> >              Tonté Pouncil
> 
> >              <Tonte.Pouncil@av
> 
> >              iall.com>
> To
> >                                        users@continuum.apache.org
> 
> >              03/13/2008 03:43
> cc
> >              PM                        claudior@buscape-inc.com
> 
> >
> Subject
> >                                        Re: Continuum1.1.war not
> 
> >              Please respond to        recognizing Subversion command
> 
> >              users@continuum.a        'svn' -- Need help!
> 
> >                  pache.org
> 
> >
> 
> >
> 
> >
> 
> >
> 
> >
> 
> >
> >
> >
> >
> > Is this the right way to install the svn command line (See below)?
> >
> > Thanks!
> >
> >
> >
> >              Tonté Pouncil
> >              <Tonte.Pouncil@av
> >              iall.com>
> To
> >                                        users@continuum.apache.org
> >              03/13/2008 01:28
> cc
> >              PM                        users@continuum.apache.org
> >
> Subject
> >                                        Re: Continuum1.1.war not
> >              Please respond to        recognizing Subversion command
> >              users@continuum.a        'svn' -- Need help!
> >                  pache.org
> >
> >
> >
> >
> >
> >
> >
> >
> >
> > On my Windows XP box I set up an environment variable for SVN_HOME and
> then
> > I added this variable to my PATH variable like so: %SVN_HOME%\bin;
> >
> >
> > Inactive hide details for "Claudio Ranieri" <claudior@buscape-inc.com>
> > "Claudio Ranieri" <claudior@buscape-inc.com>
> >
> >
> >                          "Claudio
> >                          Ranieri"
> >                          <claudior@b
> >                          uscape-inc.
> >                          com>
> To
> >
> >
> <users@continuum.apache.org>
> >                          03/13/2008
> >                          01:18 PM
> cc
> >
> >
> >          Please respond to
> Subject
> >      users@continuum.apache.org
> >                                              Re: Continuum1.1.war not
> >                                              recognizing Subversion
> >                                              command 'svn' -- Need help!
> >
> >
> >
> >
> >
> >
> >
> >
> >
> > Hi Tonté,
> >
> > Did you install the svn command line
> > (http://downloads.open.collab.net/collabnet-subversion.html)?
> > Did you add the svn.exe in your PATH (enviroment variables)?
> > Bye
> >
> >
> > ----- Original Message -----
> > From: "Tonté Pouncil" <Tonte.Pouncil@aviall.com>
> > To: <users@continuum.apache.org>
> > Sent: Thursday, March 13, 2008 2:47 PM
> > Subject: Fw: Continuum1.1.war not recognizing Subversion command 'svn' --
> > Need help!
> >
> >
> >
> >
> > Hi,
> >
> > I am using Continuum1.1.war on Tomcat 6.0.14 on a Windows XP box.  Can
> some
> > one help figure out why Continuum does not recognize the Subversion
> command
> > 'svn'.  I am was able to successfully add my maven2 project via the URL
> and
> > POM.  I even installed Maven tool via the Continuum installation link.
> > Subversion is install correctly on my Windows XP box.  I know this
> because
> > I have used it to create my repo and check in and out from the command
> > line.  Below are snippet of my pom where I have configure my SCM and the
> > error message I am getting.  Any help with this is GREATLY appreciated!
> >
> > Thanks!
> >
> > Tonté
> >
> > pom.xml
> >
> > <ciManagement>
> >            <system>continuum</system>
> >            <url>http://localhost/continuum</url>
> >            <notifiers>
> >                  <notifier>
> >                        <type>mail</type>
> >                        <configuration>
> >                              <address>tonte.pouncil@aviall.com</address>
> >                        </configuration>
> >                  </notifier>
> >            </notifiers>
> > </ciManagement>
> >
> > <scm>
> >
> >
> <connection>scm:svn:file:///c:/EDI_WEB_PLATFORM/svn-repos/edi</connection>
> >
> > <developerConnection>scm:svn:file:///c:/EDI_WEB_PLATFORM/svn-repos/edi
> > </developerConnection>
> > </scm>
> >
> > Error message from continuum.log
> >
> > 144779 [TP-Processor2] INFO  org.apache.maven.continuum.Continuum:default
> > - Enqueuing 'EDI Commons' with build definition 'default maven2
> > buildDefinition' - id=7).
> > 144826 [pool-1-thread-1] INFO
> > org.apache.maven.continuum.buildcontroller.BuildController:default  -
> > Initializing build
> > 144904 [pool-1-thread-1] INFO
> > org.apache.maven.continuum.buildcontroller.BuildController:default  -
> > Starting build of EDI Commons
> > 145108 [pool-1-thread-1] INFO
> > org.apache.maven.continuum.buildcontroller.BuildController:default  -
> > Updating working dir
> > 145108 [pool-1-thread-1] INFO
> > org.apache.maven.continuum.buildcontroller.BuildController:default  -
> > Performing action check-working-directory
> > 145154 [pool-1-thread-1] INFO
> > org.apache.maven.continuum.buildcontroller.BuildController:default  -
> > Performing action checkout-project
> > 145233 [pool-1-thread-1] INFO
> > org.apache.maven.continuum.scm.ContinuumScm:default  - Checking out
> > project: 'EDI Commons', id: '1' to
> >
> 'C:\EDI_WEB_PLATFORM\servers\ApacheSoftwareFoundation\apache-tomcat-6.0.14
> > \webapps\continuum\WEB-INF\working-directory\1'.
> > 145436 [pool-1-thread-1] INFO
> > org.apache.maven.scm.manager.ScmManager:default  - Executing: cmd.exe /X
> /C
> > '"svn --non-interactive checkout
> file:///c:/EDI_WEB_PLATFORM/svn-repos/edi
> > 1"'
> > 145436 [pool-1-thread-1] INFO
> > org.apache.maven.scm.manager.ScmManager:default  - Working directory:
> > C:\EDI_WEB_PLATFORM\servers\ApacheSoftwareFoundation\apache-tomcat-6.0.14
> > \webapps\continuum\WEB-INF\working-directory
> > 145576 [pool-1-thread-1] WARN
> > org.apache.maven.continuum.scm.ContinuumScm:default  - Error while
> checking
> > out the code for project: 'EDI Commons', id: '1' to
> >
> 'C:\EDI_WEB_PLATFORM\servers\ApacheSoftwareFoundation\apache-tomcat-6.0.14
> > \webapps\continuum\WEB-INF\working-directory\1'.
> > 145576 [pool-1-thread-1] WARN
> > org.apache.maven.continuum.scm.ContinuumScm:default  - Command output:
> > 'svn' is not recognized as an internal or external command,
> > operable program or batch file.
> >
> > 145576 [pool-1-thread-1] WARN
> > org.apache.maven.continuum.scm.ContinuumScm:default  - Provider message:
> > The svn command failed.
> > 145764 [pool-1-thread-1] INFO
> > org.apache.maven.continuum.buildcontroller.BuildController:default  -
> > Merging SCM results
> > 146373 [pool-1-thread-1] INFO
> > org.apache.maven.continuum.buildcontroller.BuildController:default  -
> Error
> > updating from SCM, not building
> > 147029 [pool-1-thread-1] ERROR
> >
> org.apache.maven.continuum.notification.ContinuumNotificationDispatcher:default
> 
> >
> >
> >  - Error while trying to use the mail notifier.
> >
> > _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
> _
> >
> > This e-mail message, including attachments, may contain confidential,
> > proprietary, or export controlled information.
> > Any unauthorized disclosure, distribution, or other use is prohibited,
> > unless expressly authorized.
> > If you receive this e-mail in error, please notify the sender, and delete
> > all copies of the original message from your systems.
> >
> > _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
> _
> >
> > This e-mail message, including attachments, may contain confidential,
> > proprietary, or export controlled information.
> > Any unauthorized disclosure, distribution, or other use is prohibited,
> > unless expressly authorized.
> > If you receive this e-mail in error, please notify the sender, and delete
> > all copies of the original message from your systems.
> >
> > _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
> _
> >
> > This e-mail message, including attachments, may contain confidential,
> > proprietary, or export controlled information.
> > Any unauthorized disclosure, distribution, or other use is prohibited,
> > unless expressly authorized.
> > If you receive this e-mail in error, please notify the sender, and delete
> > all copies of the original message from your systems.
> >
> >
> >
> >
> >
> >
> >
> >
> >
> 
> 
> 
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message