continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mick Knutson" <mickknut...@gmail.com>
Subject Re: [c 1.1] issues with adding build definition....
Date Fri, 01 Feb 2008 20:58:44 GMT
In my localhost.log I see this:

*SEVERE: Exception starting filter Compression Filter
java.lang.ClassNotFoundException: compressionFilters.CompressionFilter
    at org.apache.catalina.loader.WebappClassLoader.loadClass(
WebappClassLoader.java:1362)
    at org.apache.catalina.loader.WebappClassLoader.loadClass(
WebappClassLoader.java:1208)
    at org.apache.catalina.core.ApplicationFilterConfig.getFilter(
ApplicationFilterConfig.java:207)
    at org.apache.catalina.core.ApplicationFilterConfig.setFilterDef(
ApplicationFilterConfig.java:302)
    at org.apache.catalina.core.ApplicationFilterConfig.<init>(
ApplicationFilterConfig.java:78)
    at org.apache.catalina.core.StandardContext.filterStart(
StandardContext.java:3635)
    at org.apache.catalina.core.StandardContext.start(StandardContext.java
:4222)
    at org.apache.catalina.core.ContainerBase.addChildInternal(
ContainerBase.java:760)
    at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java
:740)
    at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:544)
    at org.apache.catalina.startup.HostConfig.deployDirectory(
HostConfig.java:920)
    at org.apache.catalina.startup.HostConfig.deployDirectories(
HostConfig.java:883)
    at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java
:492)
    at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1138)
    at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java
:311)
    at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(
LifecycleSupport.java:120)
    at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1022)
    at org.apache.catalina.core.StandardHost.start(StandardHost.java:736)
    at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1014)
    at org.apache.catalina.core.StandardEngine.start(StandardEngine.java
:443)
    at org.apache.catalina.core.StandardService.start(StandardService.java
:448)
    at org.apache.catalina.core.StandardServer.start(StandardServer.java
:700)
    at org.apache.catalina.startup.Catalina.start(Catalina.java:552)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(
NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(
DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:433)
Feb 1, 2008 12:45:18 PM org.apache.catalina.core.StandardContext filterStart
SEVERE: Exception starting filter Set Character Encoding
java.lang.ClassNotFoundException: filters.SetCharacterEncodingFilter
    at org.apache.catalina.loader.WebappClassLoader.loadClass(
WebappClassLoader.java:1362)
    at org.apache.catalina.loader.WebappClassLoader.loadClass(
WebappClassLoader.java:1208)
    at org.apache.catalina.core.ApplicationFilterConfig.getFilter(
ApplicationFilterConfig.java:207)
    at org.apache.catalina.core.ApplicationFilterConfig.setFilterDef(
ApplicationFilterConfig.java:302)
    at org.apache.catalina.core.ApplicationFilterConfig.<init>(
ApplicationFilterConfig.java:78)
    at org.apache.catalina.core.StandardContext.filterStart(
StandardContext.java:3635)
    at org.apache.catalina.core.StandardContext.start(StandardContext.java
:4222)
    at org.apache.catalina.core.ContainerBase.addChildInternal(
ContainerBase.java:760)
    at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java
:740)
    at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:544)
    at org.apache.catalina.startup.HostConfig.deployDirectory(
HostConfig.java:920)
    at org.apache.catalina.startup.HostConfig.deployDirectories(
HostConfig.java:883)
    at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java
:492)
    at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1138)
    at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java
:311)
    at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(
LifecycleSupport.java:120)
    at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1022)
    at org.apache.catalina.core.StandardHost.start(StandardHost.java:736)
    at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1014)
    at org.apache.catalina.core.StandardEngine.start(StandardEngine.java
:443)
    at org.apache.catalina.core.StandardService.start(StandardService.java
:448)
    at org.apache.catalina.core.StandardServer.start(StandardServer.java
:700)
    at org.apache.catalina.startup.Catalina.start(Catalina.java:552)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(
NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(
DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:433)*


On Feb 1, 2008 12:58 PM, Mick Knutson <mickknutson@gmail.com> wrote:

> 1st, when I start a new project group, and single build definition.
> Everything works fine. My install works, and I get an email each time the
> build occurs.
>
> Now when I add another build definition, the 1st time the build happened
> with the new definition, it appears the install works, but the site:site
> (2nd definition) seems to have an error getting the dashboard plugin as it
> thinks there is no valid version available, but I am using archiva, and I
> can assure you that running site:site from the command line in the source of
> the machine works.
> This error continues each time the build runs, but the 1st definition
> never runs again. Only the 2nd build definition (site:site) is run from now
> on.
>
> Then, I delete the 2nd build definition (site:site) and bounce continuum.
> Then the 1st build definition starts working again, but now the email
> notifier does not work anymore.
>
> This all occurs without any Clearcase code change at all.
>
>
>
> --
> Thanks,
> Mick Knutson
>
> http://www.baselogic.com
> http://www.blincmagazine.com
> http://www.djmick.com
> http://www.myspace.com/mickknutson
> http://www.myspace.com/BLiNCMagazine
> http://tahoe.baselogic.com
> ---




-- 
Thanks,
Mick Knutson

http://www.baselogic.com
http://www.blincmagazine.com
http://www.djmick.com
http://www.myspace.com/mickknutson
http://www.myspace.com/BLiNCMagazine
http://tahoe.baselogic.com
---

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message