continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ewryan <>
Subject Sub modules don't find parent pom
Date Tue, 12 Feb 2008 16:44:30 GMT

I am having trouble getting Continuum to successfully build my multi-module
maven2 project.  

My project structure is as follows: 

	--pom.xml (parent)

Because my CVS repo has no http access, I added my project using
file:///path/to/Root/pom.xml.  Continuum then connects to my CVS repo using
the scm connection credentials defined by my parent pom (as well as the
username info defined in settings.xml).  It successfully checks out a
working copy with all submodules over ssh.  I then have separate projects
listed as Member Projects in the Continuum Project Group Summary:


In my Continuum Build Definition am trying to run the clean and package
goals with no arguments, but the builds of the Root and subModles fail.  The
error I receive follows:

[INFO] Error building POM (may not be this project's POM).

Project ID: null:moduleA:jar:null

Reason: Cannot find parent: ${myGroupId}:${myArtifactId} for project:
null:moduleA:jar:null for project null:moduleA:jar:null

${myGroupId} and ${myArtifactId} variables are defined in the parent pom. 
It seems as though ${myGroupId} ${myArtifactId} are not being picked up by
the submodules.  How can I get these variables to be recognized up by the
View this message in context:
Sent from the Continuum - Users mailing list archive at

View raw message