continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier Lamy" <ol...@apache.org>
Subject Re: Upgrade from 1.1-beta-3 to 1.1 failed
Date Thu, 03 Jan 2008 17:29:03 GMT
Hi,
If you move to 1.1 final. Use data-management-cli-1.1-app.jar.
It looks you some missing jars here especially continuum-store-1.1.jar [2].

But the best is to have an internet acces here (you can't use a proxy ?)

--
Olivier

[1] http://repo1.maven.org/maven2/org/apache/maven/continuum/data-management-cli/1.1/data-management-cli-1.1-app.jar

[2] http://repo1.maven.org/maven2/org/apache/maven/continuum/continuum-store/1.1/continuum-store-1.1.jar

2008/1/3, stephane pain <stephane.pain-prestataire@lcl.fr>:
>
> Hi,
>
>    I use Continuum 1.1-beta-3 and I want to update it to 1.1 final. I
> followed the instructions for upgrade, but I can't export data from my old
> version.
>
> I have downloaded data-management-cli-1.1-beta-3-app.jar and execute thie
> command :
> java -Xmx512m -jar data-management-cli-1.1-beta-4-app.jar -buildsJdbcUrl
> jdbc:derby:${old.continuum.home}/data/continuum/database -mode EXPORT
> -directory backups
>
> This doesn't work because it can find some jar in the remote repository
> (maybe because the server can't acces to Internet). So, I have had this jars
> to my local repository :
> - derby-10.1.3.1.jar
> - data-management-jdo-1.1-beta-3.jar
> - jpox-1.1.6.jar
>
> After this, I had an exception because it can't find the class
> ContinuumStoreException. So I have had the jar continuum-api-1.1-beta-3.jar
> in the classpath.
>
> And now, this doesn't work because it can't find a component descriptor in
> the component repository :
>
> 0 [main] INFO org.apache.maven.continuum.management.DataManagementCli  -
> Processing Continuum database...
> Exception in thread "main"
> org.codehaus.plexus.component.repository.exception.ComponentLookupException:
> Unable to lookup
>  component 'org.apache.maven.continuum.management.DataManagementTool', it
> could not be started
>         at
> org.codehaus.plexus.DefaultComponentLookupManager.lookup(DefaultComponentLookupManager.java:156)
>         at
> org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:333)
>         at
> org.apache.maven.continuum.management.DataManagementCli.processDatabase(DataManagementCli.java:233)
>         at
> org.apache.maven.continuum.management.DataManagementCli.main(DataManagementCli.java:146)
> Caused by:
> org.codehaus.plexus.component.repository.exception.ComponentLifecycleException:
> Error starting component
>         at
> org.codehaus.plexus.component.manager.AbstractComponentManager.startComponentLifecycle(AbstractComponentManag
> er.java:146)
>         at
> org.codehaus.plexus.component.manager.AbstractComponentManager.createComponentInstance(AbstractComponentManag
> er.java:132)
>         at
> org.codehaus.plexus.component.manager.ClassicSingletonComponentManager.getComponent(ClassicSingletonComponent
> Manager.java:90)
>         at
> org.codehaus.plexus.DefaultComponentLookupManager.lookup(DefaultComponentLookupManager.java:147)
>         ... 3 more
> Caused by:
> org.codehaus.plexus.personality.plexus.lifecycle.phase.PhaseExecutionException:
> Error composing component
>         at
> org.codehaus.plexus.personality.plexus.lifecycle.phase.CompositionPhase.execute(CompositionPhase.java:53)
>         at
> org.codehaus.plexus.lifecycle.AbstractLifecycleHandler.start(AbstractLifecycleHandler.java:128)
>         at
> org.codehaus.plexus.component.manager.AbstractComponentManager.startComponentLifecycle(AbstractComponentManag
> er.java:142)
>         ... 6 more
> Caused by: org.codehaus.plexus.component.composition.CompositionException:
> Composition failed of field store in object o
> f type org.apache.maven.continuum.management.JdoDataManagementTool because
> the requirement ComponentRequirement{role='or
> g.apache.maven.continuum.store.ContinuumStore', roleHint='jdo',
> fieldName='store'} was missing (lookup realm: app)
>         at
> org.codehaus.plexus.component.composition.AbstractComponentComposer.findRequirement(AbstractComponentComposer
> .java:245)
>         at
> org.codehaus.plexus.component.composition.FieldComponentComposer.assignRequirementToField(FieldComponentCompo
> ser.java:66)
>         at
> org.codehaus.plexus.component.composition.FieldComponentComposer.assignRequirement(FieldComponentComposer.jav
> a:57)
>         at
> org.codehaus.plexus.component.composition.AbstractComponentComposer.assembleComponent(AbstractComponentCompos
> er.java:142)
>         at
> org.codehaus.plexus.component.composition.DefaultComponentComposerManager.assembleComponent(DefaultComponentC
> omposerManager.java:72)
>         at
> org.codehaus.plexus.personality.plexus.lifecycle.phase.CompositionPhase.execute(CompositionPhase.java:46)
>         ... 8 more
> Caused by:
> org.codehaus.plexus.component.repository.exception.ComponentLookupException:
> Component descriptor cannot be f
> ound in the component repository:
> org.apache.maven.continuum.store.ContinuumStore [jdo] (lookup realm:
> ClassRealm[app, p
> arent: ClassRealm[plexus.core, parent: null]]).
>         at
> org.codehaus.plexus.DefaultComponentLookupManager.lookup(DefaultComponentLookupManager.java:139)
>         at
> org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:333)
>         at
> org.codehaus.plexus.component.composition.AbstractComponentComposer.findRequirement(AbstractComponentComposer
> .java:232)
>         ... 13 more
>
>
> Thank you for your help
>
> St├ęphane
> --
> View this message in context: http://www.nabble.com/Upgrade-from-1.1-beta-3-to-1.1-failed-tp14596899p14596899.html
> Sent from the Continuum - Users mailing list archive at Nabble.com.
>
>

Mime
View raw message