continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tawfik, Sameh E" <SamehTaw...@fairisaac.com>
Subject RE: Continuum 1.1 standalone on WindowsXP doesn't send email?
Date Mon, 28 Jan 2008 23:52:50 GMT

Hi Emmanuel,

The problem is resolved. It was as you specified earlier when you asked:

 > 1- are you sure your smtp server use ssl?

When I updated :\continuum-1.1\conf\plexus.xml, I took the default
settings which uses ssl as follow:

<property>
   <name>mail.smtp.socketFactory.class</name>
       <value>javax.net.ssl.SSLSocketFactory</value>
</property>

And after, I set the "alwaysSend" property to true, when the build run,
I see the following error messages:

jvm 1    | DEBUG: setDebug: JavaMail version 1.4ea
jvm 1    | DEBUG: getProvider() returning
javax.mail.Provider[TRANSPORT,smtp,com.sun.mail.smtp.SMTPTransport,Sun
Microsystems, Inc]
jvm 1    | DEBUG SMTP: useEhlo true, useAuth true
jvm 1    | DEBUG SMTP: trying to connect to host "mail.fairisaac.com",
port 25, isSSL false
jvm 1    | DEBUG SMTP: exception reading response:
javax.net.ssl.SSLException: Unrecognized SSL message, plaintext
connection?
jvm 1    | 2008-01-25 14:12:13,713 [pool-1-thread-1] ERROR
org.apache.maven.continuum.notification.ContinuumNotificationDispatcher:
default  - Error while
trying to use the mail notifier.
jvm 1    | org.codehaus.plexus.notification.NotificationException:
Exception while sending message.

I verified that we are not using ssl, followed by removing the above ssl
property segment from \continuum-1.1\conf\plexus.xml, so now after the
build is complete, Continuum is able to successfully send email with the
build results.

   Thanks,
 
     Sameh


-----Original Message-----
From: emmanuel.venisse@gmail.com [mailto:emmanuel.venisse@gmail.com] On
Behalf Of Emmanuel Venisse
Sent: Friday, January 25, 2008 12:57 AM
To: continuum-users@maven.apache.org
Subject: Re: Continuum 1.1 standalone on WindowsXP doesn't send email?

You can configure it in
.../WEB-INF/classes/META-INF/plexus/application.xml

You'll find in this file some "alwaysSend" parameters

Emmanuel

On Jan 25, 2008 2:55 AM, Tawfik, Sameh E <SamehTawfik@fairisaac.com>
wrote:

>
> I found the following info from the Continuum screen that launches
when
> I click on C:\continuum-1.1\bin\windows-x86-32\run.bat
>
>
> jvm 1    | 2008-01-24 17:28:14,982 [pool-1-thread-1] INFO
> org.codehaus.plexus.notification.notifier.Notifier:msn  - Same state,
> not sending message.
> jvm 1    | 2008-01-24 17:28:14,998 [pool-1-thread-1] INFO
> org.codehaus.plexus.notification.notifier.Notifier:mail  - Same state,
> not sending message.
>
> So, is there is any way to force it to send an email. We need to know
> the results of the build? And I do not know if the email part is
working
> or not yet?
>
>  Sameh
>
> -----Original Message-----
> From: Tawfik, Sameh E [mailto:SamehTawfik@fairisaac.com]
> Sent: Thursday, January 24, 2008 5:23 PM
> To: continuum-users@maven.apache.org
> Subject: RE: Continuum 1.1 standalone on WindowsXP doesn't send email?
>
>
> We're using Microsoft Exchange Server, so when I add a Notifier which
> choice to choose? is it mail, or MSN?
>
>   Sameh
>
> -----Original Message-----
> From: Tawfik, Sameh E [mailto:SamehTawfik@fairisaac.com]
> Sent: Thursday, January 24, 2008 4:41 PM
> To: continuum-users@maven.apache.org
> Subject: RE: Continuum 1.1 standalone on WindowsXP doesn't send email?
>
>
>
> Emmanuel,
>
> I'm not sure if our server uses ssl? But I'm working on finding out.
>
> And, I need Continuum to always send email to a specific email group,
> every time it runs a build whether it's successful or not. I'm hoping
> Continuum can do that without going through too many steps?
>
> Also, I noticed whenever I run a build; the icons do not change unless
I
> press F5 to refresh the screen! So, is there is a way, where I can
have
> Continuum automatically updates the build icons? So it would be easy
to
> visually know that the build is complete? Do I need to modify or reset
> something? I worked with other auto build tools, where whenever you
run
> a build you'd see the icon is moving and then it change its shape to
> indicate that the build is done.
>
> Finally, do you know of any example that I can view to see how the
email
> section is set in the C:\continuum-1.1\conf\plexus.xml file? That
would
> help a lot.
>
>   Thanks,
>
>  Sameh
>
> -----Original Message-----
> From: emmanuel.venisse@gmail.com [mailto:emmanuel.venisse@gmail.com]
On
> Behalf Of Emmanuel Venisse
> Sent: Thursday, January 24, 2008 3:29 PM
> To: continuum-users@maven.apache.org
> Subject: Re: Continuum 1.1 standalone on WindowsXP doesn't send email?
>
> 1- are you sure your smtp server use ssl?
> 2- Continuum doesn't send a mail for each build by default but only
when
> the
> project state change to prevent some spam
>
> Emmanuel
>
> On Jan 25, 2008 12:23 AM, Tawfik, Sameh E <SamehTawfik@fairisaac.com>
> wrote:
>
> >
> >
> > I opened the correct file, and made the following modification,
> > restarted Continuum, followed by logging as an admin, run a build,
but
> > still Continuum is not sending any email?
> >
> >
> >          <resource>
> >            <name>mail/Session</name>
> >            <type>javax.mail.Session</type>
> >            <properties>
> >              <property>
> >                <name>mail.smtp.host</name>
> >                <value>STPMSGMxyz.corp.fairisaac.com</value>
> >              </property>
> >              <property>
> >                <name>mail.smtp.port</name>
> >                <value>25</value>
> >              </property>
> >
> >              <property>
> >                <name>mail.smtp.auth</name>
> >                <value>true</value>
> >              </property>
> >              <property>
> >                <name>mail.smtp.user</name>
> >                <value>SamehTawfik</value>
> >              </property>
> >              <property>
> >                <name>password</name>
> >                <value>xxxxx</value>
> >              </property>
> >              <property>
> >                <name>mail.smtp.debug</name>
> >                <value>true</value>
> >              </property>
> >              <property>
> >                <name>mail.smtp.starttls.enable</name>
> >                <value>true</value>
> >              </property>
> >              <property>
> >                <name>mail.smtp.socketFactory.class</name>
> >                <value>javax.net.ssl.SSLSocketFactory</value>
> >              </property>
> >            </properties>
> >          </resource>
> >
> > -----Original Message-----
> > From: emmanuel.venisse@gmail.com [mailto:emmanuel.venisse@gmail.com]
> On
> > Behalf Of Emmanuel Venisse
> > Sent: Thursday, January 24, 2008 2:56 PM
> > To: continuum-users@maven.apache.org
> > Subject: Re: Continuum 1.1 standalone on WindowsXP doesn't send
email?
> >
> > You looked at the wrong file, It should be
> > C:\continuum-1.1\conf\plexus.xml and the file is similar to this one
:
> >
>
https://svn.apache.org/repos/asf/maven/continuum/branches/continuum-1.x/
> > continuum-plexus-runtime/src/conf/plexus.xml
> >
> > On Jan 24, 2008 11:51 PM, Tawfik, Sameh E
<SamehTawfik@fairisaac.com>
> > wrote:
> >
> > >
> > > I just opened C:\continuum-1.1\apps\continuum\conf\plexus.xml and
it
> > is
> > > empty!
> > >
> > > Could you let me know what the required syntax to add to this
file?
> > >
> > >  Thanks,
> > >
> > >    Same
> > >
> > > -----Original Message-----
> > > From: emmanuel.venisse@gmail.com
[mailto:emmanuel.venisse@gmail.com]
> > On
> > > Behalf Of Emmanuel Venisse
> > > Sent: Thursday, January 24, 2008 2:37 PM
> > > To: continuum-users@maven.apache.org
> > > Subject: Re: Continuum 1.1 standalone on WindowsXP doesn't send
> email?
> > >
> > > Do you have configured your smtp server in conf/plexus.xml?
> > >
> > >
> > > On Jan 24, 2008 11:25 PM, Tawfik, Sameh E
> <SamehTawfik@fairisaac.com>
> > > wrote:
> > >
> > > >
> > > > Hi,
> > > >
> > > > According to the help documentation, the following is all I need
> to
> > > have
> > > > Continuum send an email when it done from running a build, but
> > > Continuum
> > > > does not send any email as it supposed to when it's done from a
> > build!
> > > >
> > > > I set the following under the Notifiers section of the project,
> but
> > > > nothing happens?
> > > >
> > > > Type     Recipient                  Events
> > > > From
> > > > mail   SamehTawfik@FairIsaac.com
> Success/Failures/Warnings/Errors
> > > > User
> > > >
> > > >
> > > >  Sameh
> > > >
> > > > This email and any files transmitted with it are confidential,
> > > proprietary
> > > > and intended solely for the individual or entity to whom they
are
> > > > addressed.
> > > > If you have received this email in error please delete it
> > immediately.
> > > >
> > > >
> > > This email and any files transmitted with it are confidential,
> > proprietary
> > > and intended solely for the individual or entity to whom they are
> > > addressed.
> > > If you have received this email in error please delete it
> immediately.
> > >
> > >
> > This email and any files transmitted with it are confidential,
> proprietary
> > and intended solely for the individual or entity to whom they are
> > addressed.
> > If you have received this email in error please delete it
immediately.
> >
> >
> This email and any files transmitted with it are confidential,
> proprietary
> and intended solely for the individual or entity to whom they are
> addressed.
> If you have received this email in error please delete it immediately.
>
>
> This email and any files transmitted with it are confidential,
> proprietary
> and intended solely for the individual or entity to whom they are
> addressed.
> If you have received this email in error please delete it immediately.
>
>
> This email and any files transmitted with it are confidential,
proprietary
> and intended solely for the individual or entity to whom they are
> addressed.
> If you have received this email in error please delete it immediately.
>
>
This email and any files transmitted with it are confidential, proprietary
and intended solely for the individual or entity to whom they are addressed.
If you have received this email in error please delete it immediately.


Mime
View raw message