continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mick Knutson" <mickknut...@gmail.com>
Subject archiva setup question as repository
Date Sat, 15 Dec 2007 01:44:01 GMT
I have my archiva defined in my pom.xml:

    <repositories>
        <repository>
            <id>dap.internal</id>
            <name>DAP Managed Internal Repository</name>
            <url>
http://rc-sun66e.ut.dentegra.lab:8081/archiva/repository/internal/</url>
            <releases>
                <enabled>true</enabled>
            </releases>
            <snapshots>
                <enabled>false</enabled>
            </snapshots>
        </repository>
    </repositories>

Then the mirror in my settings.xml:

        <mirror>
          <id>dap.internal</id>
          <url>dav:
http://rc-sun66e.ut.dentegra.lab:8081/archiva/repository/internal/</url>
          <mirrorOf>*</mirrorOf>
        </mirror>


When I go to the UI and look for "regexp:regexp:jar:1.3" it was not in the
REPO, but then it went and downloaded it, so now when I browser I can see
"archiva/browse/regexp/regexp/1.3/" and the jar description.

Now when I run a clean package, the jar in not in my local repo, and tries
to download it but does not find it:


[INFO] Failed to resolve artifact.

Missing:
----------
1) regexp:regexp:jar:1.3

  Try downloading the file manually from the project website.

  Then, install it using the command:
      mvn install:install-file -DgroupId=regexp -DartifactId=regexp \
          -Dversion=1.3 -Dpackaging=jar -Dfile=/path/to/file
Alternatively, if you host your own repository you can deploy the file
there:       mvn deploy:deploy-file -DgroupId=regexp -DartifactId=regexp \
          -Dversion=1.3 -Dpackaging=jar -Dfile=/path/to/file \
           -Durl=[url] -DrepositoryId=[id]

  Path to dependency:
        1)
org.codehaus.mojo:buildnumber-maven-plugin:maven-plugin:1.0-beta-1-SNAPSHOT
        2) org.apache.maven.scm:maven-scm-provider-perforce:jar:1.0-beta-3
        3) regexp:regexp:jar:1.3

----------
1 required artifact is missing.

for artifact:

org.codehaus.mojo:buildnumber-maven-plugin:maven-plugin:1.0-beta-1-SNAPSHOT

from the specified remote repositories:
  codehaus.org (http://snapshots.repository.codehaus.org),
  central (http://repo1.maven.org/maven2),
  dap.internal (
http://rc-sun66e.ut.dentegra.lab:8081/archiva/repository/internal/)




Any ideas on how to resolve this?




-- 
Thanks,
Mick Knutson

http://www.baselogic.com
http://www.blincmagazine.com
http://www.djmick.com
http://www.myspace.com/mickknutson
http://www.myspace.com/BLiNCMagazine
http://tahoe.baselogic.com
---

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message