continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hemant Malik" <hemant.ma...@gmail.com>
Subject Re: JVM Appears to be hung
Date Wed, 19 Dec 2007 15:13:17 GMT
Hi,
I was able to overcome this problem by deploying continuum war on tomcat.
Just browsing through the continuum bug list i came across some bug that was
related to jvm and jetty, so just as a wild guess i thought of doing it. And
on tomcat continuum is running fine. I know there is nothing to infer from
this fluke but yeah it worked for me.


Regards,
Hemant Malik

On Dec 19, 2007 7:58 PM, Boeckli, Dominique <dominique.boeckli@eds.com>
wrote:

> i had same problem and figured out that is was deadlock due to a log4j bug
> (http://issues.apache.org/bugzilla/show_bug.cgi?id=43568):
>
> This deadlock happens under following cases:
>
> - Proximity RC9 and Continuum-1.1 on same server
> - both has a scheduled task at the same time (a purge task for proximity
> and build task for continuum).
>
> There's no fix for this bug but you can reduce the probability that is
> happens:
> - don't set start time for proximity and continuum task at the same time.
>
> brgds
>
> Dominique
>
> -----Original Message-----
> From: Hemant Malik [mailto:hemant.malik@gmail.com]
> Sent: Monday, December 03, 2007 08:13 AM
> To: continuum-users@maven.apache.org
> Subject: Re: JVM Appears to be hung
>
> Actually the problem for me is that I don't want the jvm to be killed.
> After taking sometime the Apache continuum Console restarts the JVM telling
> " JVM appears to be hung...... " which is killing my enqueued processes and
> thus losing the schedule :(
>
> Hemant
>
> On Dec 3, 2007 12:35 PM, Dan Tran <dantran@gmail.com> wrote:
>
> > I had one case where continuum's jvm spined.  I had to killl the jvm
> > and restart continuum.
> >
> > my system is jvm 1.5, windows running in non service mode.
> >
> >
> > -D
> >
> > On Dec 2, 2007 10:13 PM, Hemant Malik <hemant.malik@gmail.com> wrote:
> > > Hi,
> > > Has anyone come across a similar problem? I am not able to cope up
> > > with
> > the
> > > "JVM appears to be hung" error. Somebody kindly please help.
> > > Is this a bug or am I lacking somewhere?
> > >
> > >
> > > Regards,
> > > Hemant Malik
> > >
> > >
> > > On Nov 29, 2007 9:30 PM, Hemant Malik <hemant.malik@gmail.com> wrote:
> > >
> > > > I tried increasing the PermSize and Heap Size, but no effect.
> > > >
> > > > Hemant
> > > >
> > > >
> > > > On Nov 29, 2007 9:19 PM, Hemant Malik <hemant.malik@gmail.com>
> wrote:
> > > >
> > > > > My OS is Windows XP with SP2.
> > > > >
> > > > > Regards,
> > > > > Hemant Malik
> > > > >
> > > > >
> > > > > On Nov 29, 2007 8:58 PM, Emmanuel Venisse <emmanuel@venisse.net>
> > wrote:
> > > > >
> > > > > > What is your OS?
> > > > > >
> > > > > > Emmanuel
> > > > > >
> > > > > > Hemant Malik a écrit :
> > > > > > > Hi,
> > > > > > > We are in the phase of adapting to the Continuum as CI
tool
> > > > > > > here
> > at
> > > > > > our
> > > > > > > organization.We are using the latest version available
on
> > Continuum
> > > > > > Home.
> > > > > > > For the testing purposes the Continuum worked beautifully
> > > > > > > but
> > with
> > > > > > actual
> > > > > > > project from CVS, its taking quite a bit of time, after
the
> > checkout
> > > > > > when I
> > > > > > > give the build command, after waiting for certain time
"JVM
> > appears
> > > > > > to be
> > > > > > > hung" error comes and the JVM gets restarted, hence I loose
> > > > > > > the
> > > > > > earlier
> > > > > > > progress in the build.
> > > > > > >
> > > > > > > Could please someone help out as if it is a configuration
> > problem
> > > > > > somewhere
> > > > > > > or anything more serious?
> > > > > > > The exact error is :
> > > > > > > "*
> > > > > > > ERROR  | wrapper  | 2007/11/29 19:17:18 | JVM appears hung:
> > Timed
> > > > > > out
> > > > > > > waiting for signal from JVM.
> > > > > > > ERROR  | wrapper  | 2007/11/29 19:17:18 | JVM did not exit
> > > > > > > on
> > > > > > request,
> > > > > > > terminated
> > > > > > > STATUS | wrapper  | 2007/11/29 19:17:24 | Launching a
> > > > > > > JVM...* "
> > > > > > >
> > > > > > > Regards,
> > > > > > > Hemant Malik
> > > > > > >
> > > > > > > We are working with :
> > > > > > > 1) Maven 2.0.7
> > > > > > > 2) CVS
> > > > > > > 3) Continuum 1.1
> > > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message