continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Venisse <emman...@venisse.net>
Subject Re: hi, i need some help with mail notifications
Date Mon, 03 Dec 2007 14:13:49 GMT
Your smtp server requires a SSL connection or a plain text?

Emmanuel

Gerhard a écrit :
> I got it to try and send, but now I get another exception?
> DEBUG SMTP: exception reading response: javax.net.ssl.SSLException:
> Unrecognized SSL message, plaintext connection?
> ???
> 
> Here is my resource entry into the plexus.xml
> <resource>
>             <name>mail/Session</name>
>             <type>javax.mail.Session</type>
>             <properties>
>               <property>
>                 <name>mail.smtp.host</name>
>                 <value>1**.***.0.***</value>
>               </property>
>               <property>
>                 <name>mail.smtp.port</name>
>                 <value>25</value>
>               </property>
>                
>               <property> 
>                 <name>mail.smtp.auth</name>
>                 <value>false</value>
>               </property>
>               <property>
>                 <name>mail.smtp.user</name>
>                 <value>gerhardg@loyaltyplus.co.za</value>
>               </property>
>               <property>
>                 <name>password</name>
>                 <value>******</value>
>               </property>
>               <property>
>                 <name>mail.smtp.debug</name>
>                 <value>true</value>
>               </property>
>               <property>
>                 <name>mail.smtp.starttls.enable</name>
>                 <value>true</value>
>               </property>
>               <property>
>                 <name>mail.smtp.socketFactory.class</name>
>                 <value>javax.net.ssl.SSLSocketFactory</value>
>               </property>
>                
>             </properties>
>           </resource>
> 
> What am I doing wrong?
> thanks
> 
> 
> 
> -----Original Message-----
> From: Gerhard [mailto:gerhardg@loyaltyplus.co.za] 
> Sent: 03 December 2007 03:15 PM
> To: continuum-users@maven.apache.org
> Subject: hi, i need some help with mail notifications
> 
> Hi I just installed Continuum 1.1 and got it to build a Simple ant project. 
> 
> I am now trying to setup some notification on success/failure. I followed
> the gmail smtp setup and told it to use my gmail account.
> 
>  
> 
> I get the following from the log.
> 
>  
> 
> jvm 1    | 2007-12-03 15:00:47,438 [pool-1-thread-1] INFO
> org.codehaus.plexus.notification.notifier.Notifier:mail  - Same state, not
> sending message.
> 
>  
> 
> Any guidance will be greatly appreciated. 
> 
>  
> 
>  
> 
> Regards
> 
> Gerhard Goosen 
> 
>  
> 
> 
> 
> 
> 

Mime
View raw message