continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christofer Jennings" <boz...@gmail.com>
Subject Re: trouble adding Maven 2.0 pom
Date Thu, 15 Nov 2007 21:49:03 GMT
I got SVN installed locally and set up my POM to use its repository.
Continuum can now get the files and build but I get an error about compiling
with generics. I says "use -source 5 or higher to enable generics" but I
don't know where to put "-source 5" .... hmmm

progress! :)
,chris

On Nov 15, 2007 12:35 PM, Emmanuel Venisse <emmanuel@venisse.net> wrote:

> 1. you need a real scm defined in your pom, Continuum use it to
> checkout/update the working copy and to build the project
> 2. if your scm is svn, svn must be in your PATH
>
> Emmanuel
>
> Christofer Jennings a écrit :
> > I take it back. Continuum is not happy. Each build results in ...
> > <pre>
> >
> > Provider message: The svn command failed.
> > Command output:
> >
> -------------------------------------------------------------------------------
> > 'svn' is not recognized as an internal or external command,
> > operable program or batch file.
> >
> -------------------------------------------------------------------------------
> >
> > </pre>
> >
> > So I guess I need a real SCM to run Continuum.
> >
> > ,chris
> >
> > On Nov 15, 2007 12:00 PM, Christofer Jennings <bozmoz@gmail.com> wrote:
> >
> >> Thanks Emmanuel,
> >>
> >> Ah, the FAQ. But of course :) ... sorry for that.
> >>
> >> The app I'm trying continuum has no SCM. I know. Bad Idea. But it's
> just a
> >> little thing for messing around in. .... So, for what it's worth, I
> copied
> >> the SCM settings verbatim from here:
> http://maven.apache.org/pom.html#SCMand continuum is happy now.
> >>
> >> ,chris
> >>
> >>
> >> On Nov 15, 2007 11:44 AM, Emmanuel Venisse < emmanuel@venisse.net>
> wrote:
> >>
> >>>
> >>> Christofer Jennings a écrit :
> >>>> Hi,
> >>>>
> >>>> I'm trying continuum-1.1-beta-4 and having trouble adding a maven
> >>> 2.0.7 pom.
> >>>>
> >>>> I haven't used continuum for a while, so I'm basically a newbee.
> >>>>
> >>>> If I put in a pom url like this:
> >>>>      file:///C:/wicket/wickety/pom.xml
> >>>> I get this message:
> >>>>      The specified resource isn't a file or the protocol used isn't
> >>> allowed.
> >>>
> >>> file protocol isn't allowed by default. Activation is explain in FAQs
> (
> >>> http://maven.apache.org/continuum/faqs.html)
> >>>
> >>>> If I try to upload a pom with a path like this:
> >>>>      C:\wicket\wickety\pom.xml
> >>>> I get this message:
> >>>>       Missing 'scm' element in the POM.
> >>> You must add the scm part in your pom.
> >>>
> >>>> The pom is a single module project. And I didn't change any other
> >>> fields
> >>>> from their defaults.
> >>>>
> >>>> Any ideas?
> >>>>
> >>>> Thanks in advance,
> >>>> chris
> >>>>
> >>>
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message