continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mick Knutson" <mickknut...@gmail.com>
Subject Re: [c1.1] Profile not being used in build?
Date Fri, 30 Nov 2007 22:34:47 GMT
Ok, Thanks for the clarification.

On 11/30/07, olivier lamy <olamy@apache.org> wrote:
>
> Yes .
> Continuum profile is to set some external settings for your build like
> JAVA_HOME, M2_HOME etc ..
> It's not linked to mvn profile.
> You have to put this to the arguments fields.
>
> --
> Olivier
>
> 2007/11/30, Mick Knutson <mickknutson@gmail.com>:
> >
> > No I put it in the profile section and selected that profile in the
> build
> > definition. So does that mean that those profiles are something
> different?
> >
> >
> >
> > On 11/30/07, olivier lamy <olamy@apache.org> wrote:
> > >
> > > Hi,
> > > In the arguments field of your buildDefintion do you have -P no-doc ?
> > > Continuum profile is not the same thing as maven profile.
> > >
> > > --
> > > Olivier
> > >
> > >
> > > 2007/11/30, Mick Knutson <mickknutson@gmail.com>:
> > > >
> > > > I have the following profile in my pom.xml:
> > > >
> > > >     <profiles>
> > > >         <profile>
> > > >             <id>no-doc</id>
> > > >             <activation>
> > > >                 <activeByDefault/>
> > > >             </activation>
> > > >
> > > >             <modules>
> > > >                 *<module>bpel</module>*
> > > >                 <module>business-services</module>
> > > >                 <module>common-c2</module>
> > > >             </modules>
> > > >
> > > >         </profile>
> > > >         <profile>
> > > >             <id>documentation</id>
> > > >
> > > >             <modules>
> > > >                 <module>business-services</module>
> > > >                 <module>common-c2</module>
> > > >             </modules>
> > > >
> > > >         </profile>
> > > >     </profiles>
> > > >
> > > >
> > > > When I run 'mvn -P no-doc clean install -e' I get the bpel being
> > > > created/built. but when I run through continuum, I do not:
> > > >
> > > > Build Definition Used POM filename pom.xml  Goals clean
> > > install  Arguments
> > > > -e  Build Fresh false  Always Build false  Is it default ?
> > > true  Schedule
> > > > DEFAULT_SCHEDULE  Profile no-doc  Description default maven2
> > > > buildDefinition
> > > >
> > > >
> > > > --
> > > > Thanks,
> > > > Mick Knutson
> > > >
> > > > http://www.baselogic.com
> > > > http://www.blincmagazine.com
> > > > http://www.djmick.com
> > > > http://www.myspace.com/mickknutson
> > > > http://www.myspace.com/BLiNCMagazine
> > > > http://tahoe.baselogic.com
> > > > ---
> > > >
> > >
> >
> >
> >
> > --
> > Thanks,
> > Mick Knutson
> >
> > http://www.baselogic.com
> > http://www.blincmagazine.com
> > http://www.djmick.com
> > http://www.myspace.com/mickknutson
> > http://www.myspace.com/BLiNCMagazine
> > http://tahoe.baselogic.com
> > ---
> >
>



-- 
Thanks,
Mick Knutson

http://www.baselogic.com
http://www.blincmagazine.com
http://www.djmick.com
http://www.myspace.com/mickknutson
http://www.myspace.com/BLiNCMagazine
http://tahoe.baselogic.com
---

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message