continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mick Knutson" <mickknut...@gmail.com>
Subject [c 1.0-beta-4] Error getting continuum to pick up settings.xml
Date Wed, 28 Nov 2007 21:48:35 GMT
I have my scm as:

    <scm>
        <connection>${scm.connection}</connection>
        <developerConnection>${scm.connection}</developerConnection>
        <url>${scm.url }</url>
    </scm>


*and in my continuum log I get this error:

*2243808566 [SocketListener0-1] ERROR
org.apache.maven.continuum.execution.maven.m2.MavenBuilderHelper:default
- Cannot build maven project from /opt/continuum-
1.1-beta-3/temp/continuum/viewstore/esp_lynx_dap/esp/dap/pom.xml
(The POM expression: ${scm.connection} could not be evaluated. Reason:
Expression value '${scm.connection}' references itself in '
org.delta.esp:dap:pom:E1B-1.0-SNAPSHOT' .).

But I define these values in my [user hame]/.m2/settings.xml like:

                <scm.connection
>scm:local|/opt/viewstore/esp_lynx_dap/esp|dap</scm.connection>
                <scm.url>scm:local|/opt/viewstore/esp_lynx_dap/esp|dap</scm.url>
etc...

Do I need to define my settings.xml for continuum some place?
I have even tried to create another user with the same name as the user on
my machine that has Maven setup. But that did not seem to help either.
Currently I hardcoded the values into the <scm> tag....


-- 
Thanks,
Mick Knutson

http://www.baselogic.com
http://www.blincmagazine.com
http://www.djmick.com
http://www.myspace.com/mickknutson
http://www.myspace.com/BLiNCMagazine
http://tahoe.baselogic.com
---

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message