continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Venisse <emman...@venisse.net>
Subject Re: POM file does not exist. Either the POM you specified or one of its modules does not exist.
Date Fri, 30 Nov 2007 12:28:40 GMT


Siarhei a écrit :
> I had the same problem. But in my case I had a parent which was a project
> from another repository (the build worked well from the command line) and it
> was never built on the same PC (maven didn't have a chance to download it to
> localRepository). After I removed the parent I could add the project.
> 
> Am I correct in the assumption that it's not possible to add a pom project
> that has a parent (and which may be was never installed in the local
> repository)?

You're not correct.

where is declared your localrepository? Continuum can look only at the settings.xml stored
under ${user.home}/.m2/

Emmanuel
> 
> Siarhei 
> 
> dboeckli wrote:
>> it was the first project i tried out, so i took the simpliest one, no
>> modules, no parents! 
>>
>> -----Original Message-----
>> From: Emmanuel Venisse [mailto:emmanuel@venisse.net] 
>> Sent: Monday, November 05, 2007 05:24 PM
>> To: continuum-users@maven.apache.org
>> Subject: Re: POM file does not exist. Either the POM you specified or one
>> of its modules does not exist.
>>
>> Do you have modules in your pom? Are they in the tag?
>>
>> Emmanuel
>>
>> Boeckli, Dominique a écrit :
>>> Whenever i try to add a project to Continuum i get following error:
>>>
>>> POM file does not exist. Either the POM you specified or one of its 
>>> modules does not exist.
>>>
>>> In the log i have following messages:
>>>
>>> 2007-11-05 16:14:02,175 1239586 WARN
>>> [com.opensymphony.webwork.dispatcher.multipart.MultiPartRequest]
>>> (http-0.0.0.0-8080-1:) Item is a file upload of 0 size, ignoring
>>> 2007-11-05 16:14:02,411 1239822 INFO  [STDOUT] (http-0.0.0.0-8080-1:) 
>>> [INFO]
>>> 2007-11-05 16:14:02,412 1239823 INFO  [STDOUT] (http-0.0.0.0-8080-1:) 
>>> checking for settings auth setup
>>> 2007-11-05 16:14:02,420 1239831 INFO  [STDOUT] (http-0.0.0.0-8080-1:) 
>>> [INFO]
>>> 2007-11-05 16:14:02,420 1239831 INFO  [STDOUT] (http-0.0.0.0-8080-1:) 
>>> Downloading 
>>> http://chbbs231.ch.eds.com/tweb-repos/company-eds/tags/1.0/pom.xml
>>> 2007-11-05 16:14:02,426 1239837 INFO  [STDOUT] (http-0.0.0.0-8080-1:) 
>>> [INFO]
>>> 2007-11-05 16:14:02,426 1239837 INFO  [STDOUT] (http-0.0.0.0-8080-1:) 
>>> Created 0 projects.
>>> 2007-11-05 16:14:02,426 1239837 INFO  [STDOUT] (http-0.0.0.0-8080-1:) 
>>> [INFO]
>>> 2007-11-05 16:14:02,426 1239837 INFO  [STDOUT] (http-0.0.0.0-8080-1:) 
>>> Created 0 project groups.
>>> 2007-11-05 16:14:02,426 1239837 INFO  [STDOUT] (http-0.0.0.0-8080-1:) 
>>> [INFO]
>>> 2007-11-05 16:14:02,426 1239837 INFO  [STDOUT] (http-0.0.0.0-8080-1:) 
>>> 1 errors.
>>> 2007-11-05 16:14:02,426 1239837 INFO  [STDOUT] (http-0.0.0.0-8080-1:) 
>>> [INFO]
>>> 2007-11-05 16:14:02,426 1239837 INFO  [STDOUT] (http-0.0.0.0-8080-1:) 
>>> 1 errors during project add:
>>> 2007-11-05 16:14:02,426 1239837 INFO  [STDOUT] (http-0.0.0.0-8080-1:) 
>>> [INFO]
>>> 2007-11-05 16:14:02,426 1239837 INFO  [STDOUT] (http-0.0.0.0-8080-1:) 
>>> add.project.missing.pom.error
>>>
>>> With the browser i can easily look at the pom.xml.
>>>
>>> I am using: 
>>> - continuum-webapp-1.1-beta-4.war
>>> - jboss-4.2.1
>>> - maven-2.07
>>> - subversion-1.4.3
>>>
>>> many thanks for your help
>>>
>>> kind regards
>>>
>>> Dominique
>>>
>>
>>
> 

Mime
View raw message