continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Venisse <emman...@venisse.net>
Subject Re: [c-1.1] Trying to understand my 1st multi-module ci build
Date Thu, 29 Nov 2007 08:36:12 GMT
yes, the --non-recursive is for that. Run "mvn -h" for more information about it.

Emmanuel

Mick Knutson a écrit :
> When I don't check that checkbox, I get all my pom.xml to show up, but when
> I run just my master pom.xml, the others still do not build it seems.
> Is this what the --non-recursive is for?
> 
> 
> On Nov 28, 2007 3:11 PM, Mick Knutson <mickknutson@gmail.com> wrote:
> 
>> I am trying to understand how to properly setup, and verify that my
>> project has run in v1.1
>>
>> I have added a maven2 project from my master pom.xml and checked the " For
>> multi modules project, load only root as recursive build" checkbox.
>>
>> THen when I run when I run the build, I get:L
>>
>> [INFO] Scanning for projects...
>> [INFO] ----------------------------------------------------------------------------
>> [INFO] Building Delta Dental ESP DAP Project Overview
>> [INFO]    task-segment: [clean, install]
>> [INFO] ----------------------------------------------------------------------------
>> [INFO] [clean:clean]
>> [INFO] Deleting directory /opt/continuum-1.1/apps/continuum/webapp/WEB-INF/working-directory/1/target
>> [INFO] Deleting directory /opt/continuum-1.1/apps/continuum/webapp/WEB-INF/working-directory/1/target/classes
>> [INFO] Deleting directory /opt/continuum-1.1
>> /apps/continuum/webapp/WEB-INF/working-directory/1/target/test-classes
>> [INFO] Deleting directory /opt/continuum-1.1/apps/continuum/webapp/WEB-INF/working-directory/1/target/site
>> [INFO] [buildnumber:create {execution: default}]
>> [INFO] Storing buildNumber: 2007-11-28 15:01:35 at timestamp: 1196290895955
>> [INFO] [site:attach-descriptor]
>> [INFO] [install:install]
>> [INFO] Installing /opt/continuum-1.1/apps/continuum/webapp/WEB-INF/working-directory/1/pom.xml
to /home/dapadmin/.m2/repository/org/delta/esp/dap/E1B-1.0-SNAPSHOT/dap-E1B-1.0-SNAPSHOT.pom
>> [INFO] ------------------------------------------------------------------------
>> [INFO] BUILD SUCCESSFUL
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Total time: 17 seconds
>> [INFO] Finished at: Wed Nov 28 15:01:42 PST 2007
>> [INFO] Final Memory: 13M/116M
>> [INFO] ------------------------------------------------------------------------
>>
>>
>> Now my build has >20 modules and takes about 4 minutes to build.
>> Am I missing something in the setup of this project?
>> Do I need to add each pom.xml individually? I have >20 of them.
>>
>> --
>> Thanks,
>> Mick Knutson
>>
>> http://www.baselogic.com
>> http://www.blincmagazine.com
>> http://www.djmick.com
>> http://www.myspace.com/mickknutson
>> http://www.myspace.com/BLiNCMagazine
>> http://tahoe.baselogic.com
>> ---
> 
> 
> 
> 

Mime
View raw message