continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Edward Gruber <cgru...@israfil.net>
Subject Re: Problem in 1.1-beta-4
Date Wed, 31 Oct 2007 02:31:13 GMT
Hmm.  further to this, it works on my Mac, and doesn't on my OpenBSD  
box, running jdk 1.5.0.  Before I had some problems with hte database  
not being created, which turned out to be related simply to available  
file descriptors.  At this point, I have pushed every ulimit category  
to its maximum, and I get no actual errors or problems that wuould  
indicate why it's not accepting the login.

I tried more ways, and explicitly tried bad passwords and bad  
usernames to ensure that it does, indeed, fail in more obvious ways in  
those cases.  It does.  In this case, it take it, accepts the  
password, but fails to set soemthing somewhere that is necessary for  
it to determine that the user IS logged in.  Maybe it's not creating a  
session properly?  I'm not sure.

Can I run continuum such that I get the debug output?  I'm sure I can,  
but I'm not sure what files to edit to do so.  Maybe something's  
showing in the logs.  Btu there are no ERROR logs showing at all.   
Very frustrating.  It's probably configuration of the user, but I  
can't see what, since I've maxed it all out.

Christian.

On 30-Oct-07, at 4:29 PM, Christian Edward Gruber wrote:

> Hi,
>
>   I've unzipped beta4, run it, and it asks to create the admin  
> user.  I do that, and it goes to what seems like it should be system  
> configuration, but it requires login.  I then attempt to login as  
> admin (which was just created) and for a minute it looks like it was  
> about to succeed, but then returns to the login screen.  This is  
> distinct from a bad username/password, which show an error.  this  
> just goes there like if you go to any url and you haven't been  
> authenticated.  No matter what, whether I login or go elsewhere it  
> just sends me back to the login page.
>
> The log doesn't say much - just:
>
> 2007-10-30 11:37:45,428 [SocketListener0-0] INFO   
> com.opensymphony.xwork.Action:redback-admin-account  - user =  
> UserCredentials[username=admin,fullName=Build User,email=cgruber-build@israfil.net 
> ,password=<***>,confirmPassword=<***>]
> 2007-10-30 11:37:46,123 [SocketListener0-0] INFO   
> com 
> .opensymphony 
> .xwork.interceptor.Interceptor:redbackForceAdminUserInterceptor  -  
> Admin user found. No need to configure admin user.
> 2007-10-30 11:37:47,172 [SocketListener0-0] INFO   
> com.opensymphony.xwork.Action:configuration  - baseUrl='http://207.188.87.165:8080/continuum'
> 2007-10-30 11:38:17,102 [SocketListener0-0] INFO   
> com.opensymphony.xwork.Action:configuration  - baseUrl='http://207.188.87.165:8080/continuum'
>
>
> These last two are the results of logging in as admin in the  
> subsequently delivered login screens.
>
> Any thoughts?
>
> Christian.
>


Mime
View raw message