continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Venisse <emman...@venisse.net>
Subject Re: Incorrect Build state with Maven2
Date Mon, 01 Oct 2007 14:25:59 GMT
If you run mvn 2.0.7, you can fix it with this fixed version: http://svn.apache.org/repos/asf/maven/components/branches/maven-2.0.x/maven-core/src/bin/

Emmanuel

Manuel.Renz@t-systems.com a écrit :
> Hi,
> I 've tried the tipp from the FAQs, and added 
> 	if "%MAVEN_TERMINATE_CMD%" == "on" exit %ERRORLEVEL% 
> to my mvn.bat file, but it still does not recognize the return code.
> 
> I had the same behaviour wit 1.0.3 , but could solve it with the above
> mentioned fix, but this time it does not help.
> 
> For testing I temporarily changed the maven configuration to be sure to
> get an ERROR
> Currently I'm running continuum 1.1b3
> 
> this is the maven outout:
> [INFO] Scanning for projects...
> [INFO]
> ------------------------------------------------------------------------
> ----
> [INFO] Building testproject
> [INFO]    task-segment: [clean, compile]
> [INFO]
> ------------------------------------------------------------------------
> ----
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] The plugin 'org.apache.maven.plugins:maven-clean-plugin' does not
> exist or no valid version could be found
> [INFO]
> ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: &lt; 1 second
> [INFO] Finished at: Mon Oct 01 15:31:33 CEST 2007
> [INFO] Final Memory: 1M/4M
> [INFO]
> ------------------------------------------------------------------------
> 
> 
> 
> Greetings from Germany
> Manuel
> 
> 



Mime
View raw message