continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raffaele <r.gambe...@prismasw.it>
Subject Re: Project on SVN with a not versioned parent
Date Tue, 09 Oct 2007 13:36:10 GMT

I'm using Continuum 1.1-alpha-2 under Linux.

Now it seems not to recognize the url:
svn: Unrecognized URL scheme for
'http://gea:81/data/svn/pss/application/prova/common'

Thanks, I'll do more tests...
Best regards.
Raffaele


Emmanuel Venisse wrote:
> 
> Oh, I don't know what is your continuum version, mine in 1.1-beta-3.
> 
> We fixed some url connection since 1.0.3
> 
> Emmanuel
> 
> Raffaele a écrit :
>> [SocketListener0-0] INFO  Action:create-projects-from-metadata - URL is
>> not
>> valid: http://gea81/data/svn/pss/application/prova/common/pom.xml
>> 
>> That above is the log row which write a url DIFFERENT from that one I
>> wrote
>> in the Continuum GUI.
>> Other log rows report it correclty...I DON'T KNOW what's happening....
>> 
>> 
>> Emmanuel Venisse wrote:
>>> I didn't want to reach it, I only tested your url to see if I'll get the
>>> same error gea81 instead of gea:81 in the log message
>>>
>>> Raffaele a écrit :
>>>> Emmanuel but gea is inside my company...
>>>> How could you reach that machine sorry?
>>>>
>>>>
>>>> Emmanuel Venisse wrote:
>>>>> If I use your URL,, I get this message with the right URL:
>>>>>
>>>>> jvm 1    | 2007-10-09 13:41:03,468 [SocketListener0-0] INFO 
>>>>> org.codehaus.plexus.action.Action:create-projects-from-metadata  - URL
>>>>> is
>>>>> not valid:
>>>>> http://gea:81/data/svn/pss/application/prova/common/pom.xml
>>>>> jvm 1    | java.net.UnknownHostException: gea
>>>>>
>>>>> so maybe you specified the wrong URL
>>>>>
>>>>> Emmanuel
>>>>>
>>>>> Raffaele a écrit :
>>>>>> Ok thanks,
>>>>>> Now I have Maven 2.0.7 and in my home I put the settings.xml file
>>>>>> which
>>>>>> contains all the configurations to go to our private internal
>>>>>> repository
>>>>>> on
>>>>>> Artifactory.
>>>>>>
>>>>>> Nevertheless, I've got yet some errors:
>>>>>> URL is not valid:
>>>>>> http://gea81/data/svn/pss/application/prova/common/pom.xml
>>>>>> INFO   | jvm 1    | 2007/10/09 12:40:10 |
>>>>>> java.net.UnknownHostException:
>>>>>> gea81
>>>>>>
>>>>>> I'm sure that I have specified this url:
>>>>>> http://gea:81/data/svn/pss/application/prova/common/pom.xml
>>>>>>
>>>>>> Perhaps there are some parsing bug?
>>>>>>
>>>>>> Regards.
>>>>>> Raffaele
>>>>>>
>>>>>>
>>>>>> Emmanuel Venisse wrote:
>>>>>>> Raffaele a écrit :
>>>>>>>> Ok, I'm starting to understand...
>>>>>>>>
>>>>>>>> I have performed another test specifying the pom url of "leaf"
>>>>>>>> project
>>>>>>>> named
>>>>>>>> common.
>>>>>>>> Then I went to see logs and the sensible log rows are these(I've
>>>>>>>> cut
>>>>>>>> some
>>>>>>>> shallow info):
>>>>>>>> WARN  WagonManager:default           - Unable to get resource
>>>>>>>> 'org.pss.toolkit:toolkit-parent:pom:1' from repository central
>>>>>>>> (http://repo1.maven.org/maven2)
>>>>>>>> INFO  Continuum:default              - Created 0 projects.
>>>>>>>> INFO  Continuum:default              - Created 0 project
groups.
>>>>>>>> INFO  Continuum:default              - 1 errors.
>>>>>>>> INFO  Continuum:default              - 1 errors during project
add: 
>>>>>>>> INFO  Continuum:default              -
>>>>>>>> add.project.artifact.not.found.error
>>>>>>>>
>>>>>>>> At this point it is clear that Continuum is attempting to
find
>>>>>>>> parent
>>>>>>>> pom
>>>>>>>> in
>>>>>>>> the Central repository, is right? But my parent poms are
inside
>>>>>>>> Artifactory,
>>>>>>>> but my company repository is specified inside the settings.xml
file
>>>>>>>> in
>>>>>>>> the
>>>>>>>> conf folder of maven installation.
>>>>>>> Continuum don't read settings.xml in the conf folder but in
>>>>>>> ${user.home}/.m2/
>>>>>>> It's better to store your settings here, so it is shared by
>>>>>>> continuum
>>>>>>> and
>>>>>>> all your maven installations.
>>>>>>>
>>>>>>>> A stupid question:
>>>>>>>> Continuum comes with maven or I have also to install maven
in the
>>>>>>>> machine
>>>>>>>> which hosts Continuum?
>>>>>>> You must install it.
>>>>>>>
>>>>>>> Emmanuel
>>>>>>>
>>>>>>>> Thanks again
>>>>>>>> Raffaele
>>>>>>>>
>>>>>>>>
>>>>>>>> Emmanuel Venisse wrote:
>>>>>>>>> Raffaele a écrit :
>>>>>>>>>> Which logs are you talking about? Where can I find
these logs?
>>>>>>>>> With standalone version, logs are under $CONTINUUM_HOME/logs/
>>>>>>>>> Look at wrapper.*
>>>>>>>>>
>>>>>>>>>> However my scenario is like the picture in attachment
>>>>>>>>>> http://www.nabble.com/file/p13110700/MAVEN.jpg 
>>>>>>>>>>
>>>>>>>>>> Generally how Continuum discover the different pom
inside a
>>>>>>>>>> hierarchy?
>>>>>>>>> Continuum use maven API to discover pom like maven do
it so it
>>>>>>>>> need
>>>>>>>>> to
>>>>>>>>> access to your remote repository and where it is.
>>>>>>>>>
>>>>>>>>> Emmanuel
>>>>>>>>>> Thanks and regards.
>>>>>>>>>> Raffaele
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Emmanuel Venisse wrote:
>>>>>>>>>>> I need to show your logs and where you declared
your remote
>>>>>>>>>>> repository.
>>>>>>>>>>>
>>>>>>>>>>> Emmanuel
>>>>>>>>>>>
>>>>>>>>>>> Raffaele a écrit :
>>>>>>>>>>>> Hi,
>>>>>>>>>>>>
>>>>>>>>>>>> my problem is that I am not able to add no
pom of those
>>>>>>>>>>>> specified
>>>>>>>>>>>> in
>>>>>>>>>>>> the
>>>>>>>>>>>> previous post.
>>>>>>>>>>>>
>>>>>>>>>>>> If I try to add the pom of common, it says

>>>>>>>>>>>> "Missing artifact trying to build the POM.
Check that its
>>>>>>>>>>>> parent
>>>>>>>>>>>> POM
>>>>>>>>>>>> is
>>>>>>>>>>>> available or add it first in Continuum."
>>>>>>>>>>>>
>>>>>>>>>>>> If I try to add the parent pom it says that
miss the scm
>>>>>>>>>>>> information
>>>>>>>>>>>> in
>>>>>>>>>>>> parent pom...
>>>>>>>>>>>>
>>>>>>>>>>>> How should I do in this situation? Which
should be the correct
>>>>>>>>>>>> behaviour?
>>>>>>>>>>>>
>>>>>>>>>>>> Best regards
>>>>>>>>>>>> Raffaele
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Emmanuel Venisse wrote:
>>>>>>>>>>>>> Raffaele a écrit :
>>>>>>>>>>>>>> Hi all,
>>>>>>>>>>>>>> because of the lack of documentation,
I have some
>>>>>>>>>>>>>> difficulties
>>>>>>>>>>>>>> to
>>>>>>>>>>>>>> add
>>>>>>>>>>>>>> my
>>>>>>>>>>>>>> maven2 project on Continuum, my scenario
si the following:
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> pss
>>>>>>>>>>>>>> |-- pom.xml
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> toolkit
>>>>>>>>>>>>>> |-- pom.xml
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> common
>>>>>>>>>>>>>> |-- src
>>>>>>>>>>>>>> |-- pom.xml
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> pss is parent of toolkit which is
parent of common
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> But, only common contains sources
and only it is versioned
>>>>>>>>>>>>>> using
>>>>>>>>>>>>>> Subversion.
>>>>>>>>>>>>>> The other two parents are in my local
repository and in the
>>>>>>>>>>>>>> private
>>>>>>>>>>>>>> remote
>>>>>>>>>>>>>> repository.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Thanks in advance.
>>>>>>>>>>>>>> Best regards.
>>>>>>>>>>>>>> Raffaele
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> In your opinion, how should I add
those project on Continumm?
>>>>>>>>>>>>>> Please
>>>>>>>>>>>>>> tell
>>>>>>>>>>>>>> me
>>>>>>>>>>>>>> the steps to follow.
>>>>>>>>>>>>> If they are in your remote repository,
Continuum should find
>>>>>>>>>>>>> them.
>>>>>>>>>>>>> How/where do you have declared your remote
repository?
>>>>>>>>>>>>>
>>>>>>>>>>>>> Emmanuel
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>>>>>>>>>
>>>>>
>>>>>
>>>
>>>
>> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Project-on-SVN-with-a-not-versioned-parent-tf4588826.html#a13115688
Sent from the Continuum - Users mailing list archive at Nabble.com.


Mime
View raw message