continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From noon <rami.muurim...@gmail.com>
Subject Maven2 SNAPSHOT-artifacts in Continuum
Date Wed, 03 Oct 2007 16:38:25 GMT

After googling around without finding a proper solution I decided to post a
message in here.

I'm trying to use Maven2 SNAPSHOT-versions during the development phase
where my webapp Maven2 project dependes on another Maven2 project's JAR.
When I deploy the SNAPSHOT JAR to Maven2 repository, it will be named e.g.
"myartifact-1.0-20071003.094654-1.jar" (this is the dependency that my
webapp uses). 

Using SNAPSHOT versions locally works just perfectly.

As a CI tool we're using Continuum (1.0.3). OK, after first SNAPSHOT release
Continuum works perfectly with the webapp but when I redeploy the SNAPSHOT
to Maven2 repository the deployed JAR will be named like
"myartifact-1.0-20071003.xxxxxx-2.jar" where the "xxxxxx" is some sort of
time stamp and "-2" is the build number, right? Sofar so good... However,
Continuum still uses the first SNAPSHOT version. Here's an excerpt from
Continuum build log: "resolved to version 1.0-20071003.094654-1". It never
uses any later deployed versions.

Am I missing something or am I doing this SNAPSHOT releaseasing right?

Thanks :)
-- 
View this message in context: http://www.nabble.com/Maven2-SNAPSHOT-artifacts-in-Continuum-tf4562937.html#a13022688
Sent from the Continuum - Users mailing list archive at Nabble.com.


Mime
View raw message