continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Venisse <emman...@venisse.net>
Subject Re: location of pom.xml
Date Wed, 12 Sep 2007 14:38:45 GMT
Do you have you rpom.xml in your cvs? under /cvs-repository.

Emmanuel

CyTG a écrit :
> My first post to the mailing
> 
> I must have some level of a beginners problem here, but i really cant figure
> it out!
> 
> Say i have this project
> C:\test\ConversionWebAdmin\src
> C:\test\ConversionWebAdmin\target
> C:\test\ConversionWebAdmin\logs
> C:\test\ConversionWebAdmin\pom.xml
> 
> i go here
> C:\test\ConversionWebAdmin\src
> and run
> "mvn clean install"
> and it runs fine (ok tests fail, but's partially what this is all about)
> 
> Now i add the pom in continuum as a file;
> 
> file:///C:/test/ConversionWebAdmin/pom.xml
> 
> and output from the console is as follows
> 
> INFO  Continuum:default              - Created 1 projects.
> INFO  Continuum:default              - Created 1 project groups.
> INFO  Continuum:default              - 0 errors.
> (ed. fine)
> INFO  ContinuumScm:default           - Checking out project: 'Conversion Web
> Administration', id: '23' to 'C:\continuum\continuum-1.1-beta-2\23'.
> INFO  ScmManager:default             - Executing: cmd.exe /X /C '"cvs -z3 -f
> -d :pserver:maven@xxxxxx:/cvs-repository -q checkout -d 23 Conversion"'
> INFO  ScmManager:default             - Working directory:
> C:\continuum\continuum-1.1-beta-2
> INFO  ContinuumScm:default           - Checked out 619 files.
> - and this is where trouble begins, i'll point it out loud.
>     "...to 'C:\continuum\continuum-1.1-beta-2\23'"
> So it checks out the project to homedirectory (set under config) and appends
> "\23", then sets working directory to "C:\continuum\continuum-1.1-beta-2"
> 
> - Alright, i'll try to build this sucker and i press "Build Now", and get ..
> 
> INFO  BuildController:default        - Initializing build
> INFO  BuildController:default        - Starting build of Conversion Web
> Administration
> INFO  BuildController:default        - Updating working dir
> INFO  BuildController:default        - Performing action
> check-working-directory
> INFO  BuildController:default        - Performing action
> update-working-directory-from-scm
> INFO  ContinuumScm:default           - Updating project: id: '23', name
> 'Conversion Web Administration'.
> INFO  ScmManager:default             - Executing: cmd.exe /X /C '"cvs -z3 -f
> -q update-d"'
> INFO  ScmManager:default             - Working directory:
> C:\continuum\continuum-1.1-beta-2\23
> INFO  BuildController:default        - Merging SCM results
> INFO  BuildController:default        - Changes found, building
> INFO  BuildController:default        - Performing action
> update-project-from-working-directory
> INFO  Action:update-project-from-working-directory - Updating project
> 'Conversion Web Administration' from checkout.
> ERROR BuildController:default        - Error executing action
> update-project-from-working-directory '
> org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Error
> executing action 'update-project-from-working-directory'
>     at
> org.apache.maven.continuum.buildcontroller.DefaultBuildController.performAction
> (DefaultBuildController.java:432)
>     at
> org.apache.maven.continuum.buildcontroller.DefaultBuildController.build(
> DefaultBuildController.java:137)
>     at
> org.apache.maven.continuum.buildcontroller.BuildProjectTaskExecutor.executeTask
> (BuildProjectTaskExecutor.java:50)
>     at
> org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run
> (ThreadedTaskQueueExecutor.java:116)
>     at
> edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call
> (Executors.java:442)
>     at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(
> FutureTask.java:176)
>     at
> edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask
> (ThreadPoolExecutor.java:665)
>     at
> edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run
> (ThreadPoolExecutor.java:690)
>     at java.lang.Thread.run(Thread.java:595)
>         Caused by:
> org.apache.maven.continuum.execution.ContinuumBuildExecutorException: Could
> not find Maven project descriptor.
> 
> and inspecting the log from within continuum ;
> [INFO] Scanning for projects...
> [INFO]
> ----------------------------------------------------------------------------
> [INFO] Building Maven Default Project
> [INFO]    task-segment: [clean, install]
> [INFO]
> ----------------------------------------------------------------------------
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Cannot execute mojo: clean. It requires a project with an existing
> pom.xml, but the build is not using one.
> [INFO]
> ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: &lt; 1 second
> [INFO] Finished at: Wed Sep 12 15:30:55 CEST 2007
> [INFO] Final Memory: 1M/2M
> [INFO]
> ------------------------------------------------------------------------
> 
> SO .. it seems like it cant find the pom.xml ? .. the very same pom.xml it
> used to check out the source with!
> Wonder what happens if I were to copy the pom.xml INTO the \23 directory ??
> ... lets try
> and I press the "Build Now" again... and this time i get
> [INFO] Scanning for projects...
> [INFO]
> ----------------------------------------------------------------------------
> [INFO] Building Conversion Web Administration
> [INFO]    task-segment: [clean, install]
> [INFO]
> ----------------------------------------------------------------------------
> [INFO] [clean:clean]
> [INFO] Deleting directory C:\continuum\continuum-1.1-beta-2\23\target
> [INFO] Deleting directory C:\continuum\continuum-
> 1.1-beta-2\23\target\classes
> [INFO] Deleting directory C:\continuum\continuum-
> 1.1-beta-2\23\target\test-classes
> [INFO] Deleting directory C:\continuum\continuum-1.1-beta-2\23\target\site
> [INFO] [resources:resources]
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Error loading property file 'C:\continuum\continuum-
> 1.1-beta-2\23\src\main\resources\local\webadmin.properties'
> 
> [INFO]
> ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 1 second
> [INFO] Finished at: Wed Sep 12 15:41:59 CEST 2007
> [INFO] Final Memory: 4M/8M
> [INFO]
> ------------------------------------------------------------------------
> 
> Well, apparently the "local\webadmin.properties" is NOT where it's supposed
> to be, but that's another issue.
> (based on this ONE pom.xml maven is checking out THREE different projects ..
> wth is up with that, some developer foobar? problary dependencies)
> 
> Sorry for the very very long mail, feel free to ignore it all together or
> just the irrelevant parts :)
> 
> The question in short; Why can continuum not find the pom.xml ? (same
> behavior 1.0.3 and 1.1 beta)
> 
> Best regards
> Mr.Cytg
> 
> 
> 
> 
> (ps. I also get this in the log ;
> ERROR DispatcherUtils- Error setting character encoding to 'UTF-8' -
> ignoring.
> Could that have something to do with it ? )
> 


Mime
View raw message