continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julien Stern" <julien.st...@cryptolog.com>
Subject Re: the last build is successful but the project shows as "build in error"
Date Fri, 21 Sep 2007 13:34:13 GMT
On Fri, Sep 21, 2007 at 03:13:55PM +0200, Emmanuel Venisse wrote:
> I fixed it 3 days ago, before to start the vote of 1.1-beta-3 release.

Yes, I saw that. It took me some time to actually test beta-3.
I originally though the bug was fixed too, as it did not happen
for 4 or 5 days. It really seem to happen rarely now.

What is mostly annoying with this bug is when it happens on a "stable"
project, or worse on a "parent pom". Because the project needs to
be rebuilt manually, it forces the rebuild of many projects.

What is really weird is that you could not reproduce the bug even
with very short schedule. Maybe the fact that we are using CVS
(and not SVN) as the SCM could be the difference ?
 
> For 1.1-beta-3, do you use a db from 1.1-beta-2, a new db or a db created 
> by the migration tool?

A new DB.

--
Julien

> Emmanuel
> 
> Julien Stern a écrit :
> >Emmanuel,
> >
> >just to let you know, that unfortunately, the issue
> >http://jira.codehaus.org/browse/CONTINUUM-1384
> >still happens with beta-3, albeit much less often than with beta-2.
> >
> >It happened twice in the last two weeks.
> >In both cases there was nothing in the logs except the fact that
> >the cvs update for the failing project and the schedule activator
> >were essentially triggered at the same time.
> >
> >--
> >Julien
> >
> >On Thu, Aug 30, 2007 at 02:38:00PM +0200, Emmanuel Venisse wrote:
> >>
> >>Julien Stern a écrit :
> >>>On Thu, Aug 30, 2007 at 01:36:38PM +0200, Emmanuel Venisse wrote:
> >>>>Julien Stern a écrit :
> >>>>>On Thu, Aug 30, 2007 at 03:23:13AM -0700, Ionut S wrote:
> >>>>>>Hi,
> >>>>>>I don't know for what reason one of our projects (shown when
you hit 
> >>>>>>"Show projects" link) show as "Build in error" although the last
10 
> >>>>>>or so builds are successful.
> >>>>>>
> >>>>>>Did anybody had this problem ?
> >>>>>Yes, this happens to us about twice a day with 1.1
> >>>>>It may be related to http://jira.codehaus.org/browse/CONTINUUM-1384
> >>>>>
> >>>>>You may want to check your logs to see if this is the same issue
> >>>>>or a different one.
> >>>Emmanuel,
> >>>
> >>>>Do you have it with beta-2 too?
> >>>sorry, I haven't installed beta-2 yet. I will install it and let
> >>>you know.
> >>>
> >>>>What is your default schedule?
> >>>Our default schedule is short (15 minutes) with many projects (> 200).
> >>>That's probably why we trigger this issue often.
> >>yes.
> >>
> >>>>What is the max path length for your files?
> >>>I'm not sure I understand this question.
> >>>If you mean the max length of the absolute unix file path from the cvs
> >>>root, I'd hazard a guess as between 128 and 256.
> >>it's what I meant.
> >>
> >>>I've taken a very quick look at the continuum code. I would tend to
> >>>think that this issue may be related to a project state that is not set 
> >>>back
> >>>to the correct value because two concurrent threads try to modify it
> >>>(the thread that performs the scm update and the thread that queues the
> >>>builds ?)
> >>>
> >>>Maybe (just maybe, really :) ) in the class
> >>>UpdateWorkingDirectoryFromScmContinuumAction.java the latest
> >>>store.updateProject( project ) could fail, leaving an inconsistent
> >>>state ?
> >>if the problem always exist in beta-2, yes, it should be the right place 
> >>to fix it.
> >>
> >>>Again, this is a wild guess that could be totally wrong, the continuum
> >>>code is too complex to be understood after a quick look.
> >>The code isn't too complex as you find where we can have an error about 
> >>project state ;)
> >>
> >>Emmanuel
> >>
> >>
> >
> >
> 

Mime
View raw message