continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raffaele <r.gambe...@prismasw.it>
Subject Re: svn: Directory 'target\.svn' containing working copy admin area is missing
Date Tue, 25 Sep 2007 14:46:44 GMT

I believe perhaps the problem is in the continuum working directory...here
the target folder was versioned despite I put it in the ignore list....
but I'm new to Continuum and so I stop the service, I cleaned the
C:\continuum-1.1-alpha-2\apps\continuum\webapp\WEB-INF\working-directory and
I restart Continuum.
Now I see that the target folder in that last location isn't verisioned, I
hope now it works....

Thanks again
RAffaele


Emmanuel Venisse wrote:
> 
> You can see all files/directories that aren't svn files and not in
> svn:ignores by running "svn st"
> 
> Emmanuel
> 
> Raffaele a écrit :
>> Thanks but it doesn't works!
>> I tried also to restart Continuum...
>> 
>> I have executed the following command starting from each directory of my
>> modules containing the "target" directory:
>> svn propedit svn:ignore "directory"
>> then it opens a editor where I write "target" as pattern to ignore.
>> In fact if I list the properties I see correctly my ignore list set.
>> 
>> whew!
>> Thanks in advance.
>> Raffaele
>> 
>> 
>> 
>> Nick Stolwijk-3 wrote:
>>> You should remove the target folder from your subversion repository and 
>>> ignore it by setting svn:ignore on the parent folder. That folder should 
>>> not be in version control, because it is a working area and will be 
>>> deleted by a mvn clean.
>>>
>>> Hth,
>>>
>>> Nick Stolwijk
>>>
>>> Raffaele wrote:
>>>> Hi all,
>>>>
>>>> I'm following the example in chapter 7 of Better Builds with Maven,
>>>> that
>>>> is
>>>> the example to use Continuum for the first time.
>>>>
>>>> I  was able to add example project to Continuum and to launch the build
>>>> process that successfully send me also the mails.
>>>> Nevertheless I obtain some build error...I saw in " Build result for my
>>>> project" that there was the following error:
>>>> Provider message: The svn command failed.
>>>> Command output: 
>>>> -------------------------------------------------------------------------------
>>>> svn: Directory 'target\.svn' containing working copy admin area is
>>>> missing
>>>> -------------------------------------------------------------------------------
>>>>
>>>> Perhaps that problem occurs when some folder and/or files are not
>>>> committed
>>>> and so the .svn folder doesn't exist?
>>>>
>>>> What do you think?
>>>> What else could be?
>>>>
>>>> Thanks in advance,
>>>> best regards.
>>>> Raffaele
>>>>   
>>>
>>>
>> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/svn%3A-Directory-%27target%5C.svn%27-containing-working-copy-admin-area-is-missing-tf4515395.html#a12881173
Sent from the Continuum - Users mailing list archive at Nabble.com.


Mime
View raw message