continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "LAMY Olivier" <Olivier.L...@accor.com>
Subject RE: Trying to run both Archiva and Continuum
Date Thu, 30 Aug 2007 21:24:02 GMT
Hi,
Have a look here https://svn.apache.org/repos/asf/maven/sandbox/trunk/enterprise/enterprise-runtime/pom.xml
.

This is a project which build this type of distrib.

Use the correct version for war dependencies (org.apache.maven.continuum:continuum-webapp
and org.apache.maven.archiva:archiva-webapp).

Look at the plexus.xml file [1] and add a component :

    <component>
      <role>org.codehaus.plexus.contextualizer.Contextualizer</role>
      <role-hint>jettyConfiguration</role-hint>
      <implementation>org.codehaus.plexus.contextualizer.DefaultContextualizer</implementation>
      <configuration>
        <contextValues>
          <!-- shared http port -->
          <jetty.port>8080</jetty.port>
        </contextValues>
      </configuration>
    </component>

HTH,

--
Olivier

[1]https://svn.apache.org/repos/asf/maven/sandbox/trunk/enterprise/enterprise-runtime/src/conf/plexus.xml
 

-----Message d'origine-----
De : Hilco Wijbenga [mailto:hilco.wijbenga@gmail.com] 
Envoyé : jeudi 30 août 2007 23:08
À : Archiva Users; Continuum Users
Objet : Re: Trying to run both Archiva and Continuum

P.S. I'm using the latests releases: Archiva 1.0-beta-1 and Continuum 1.1-beta-2.

On 8/30/07, Hilco Wijbenga <hilco.wijbenga@gmail.com> wrote:
> Hi all,
>
> I'm trying to set up both Archiva and Continuum on the same box. I 
> would like to have them run in the same Plexus instance and on the 
> same port number but that seems too complicated to accomplish (for me
> :-) ).
>
> I found an email by Arnaud Bailly ("Continuum+archiva in same
> application") but the information seems out of date.
>
> Giving up on one Plexus instance and a single port number ... how 
> about sharing the user database?
>
> I changed the database location in plexus.conf (both in Archiva and
> Continuum) and now both Continuum and Archiva use the same database 
> ... but apparently not at the same time. I can run either Archiva *or* 
> Continuum but not both. The app that gets started last fails to 
> connect to the user database.
>
> I had a look on the Plexus site to see if I could find anything there 
> (I assume I have to configure Plexus somehow to get this to work) but 
> no luck.
>
> Would anyone be able to shed some light on this and/or point me in the 
> right direction?
>
> Cheers,
> Hilco
>


This e-mail, any attachments and the information contained therein ("this message") are confidential
and intended solely for the use of the addressee(s). If you have received this message in
error please send it back to the sender and delete it. Unauthorized publication, use, dissemination
or disclosure of this message, either in whole or in part is strictly prohibited.
--------------------------------------------------------------------------------------------------------------
Ce message électronique et tous les fichiers joints ainsi que  les informations contenues
dans ce message ( ci après "le message" ), sont confidentiels et destinés exclusivement
à l'usage de la  personne à laquelle ils sont adressés. Si vous avez reçu ce message par
erreur, merci  de le renvoyer à son émetteur et de le détruire. Toutes diffusion, publication,
totale ou partielle ou divulgation sous quelque forme que se soit non expressément autorisées
de ce message, sont interdites.
-------------------------------------------------------------------------------------------------------------


Mime
View raw message