continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Roberts" <Eric.Robe...@borland.com>
Subject RE: Performance issues with multiple continuum instances on single server
Date Fri, 24 Aug 2007 16:11:10 GMT
As far as build timeouts are concerned, are you referring to a timeout
that can be set in continuum, in the maven pom, or that we should handle
in our custom python scripts?

As far as the maven2 project setup, I can actually set the projects up
with no problem but when I run some of them I get the following
exception:

org.apache.maven.continuum.store.ContinuumObjectNotFoundException: Could
not find object. Type
'org.apache.maven.continuum.model.project.BuildDefinition'. Id: '47'.
	at
org.apache.maven.continuum.store.JdoContinuumStore.getObjectById(JdoCont
inuumStore.java:579)
	at
org.apache.maven.continuum.store.JdoContinuumStore.getObjectById(JdoCont
inuumStore.java:567)
	at
org.apache.maven.continuum.store.JdoContinuumStore.getBuildDefinition(Jd
oContinuumStore.java:505)
	at
org.apache.maven.continuum.core.action.UpdateProjectFromWorkingDirectory
ContinuumAction.execute(UpdateProjectFromWorkingDirectoryContinuumAction
.java:56)
	at
org.apache.maven.continuum.buildcontroller.DefaultBuildController.build(
DefaultBuildController.java:273)
	at
org.apache.maven.continuum.buildcontroller.BuildProjectTaskExecutor.exec
uteTask(BuildProjectTaskExecutor.java:47)
	at
org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$Execut
orRunnable.run(ThreadedTaskQueueExecutor.java:103)
	at java.lang.Thread.run(Unknown Source)

I assume this means it's looking in the database for build definition id
47 and can't find it.  I have never seen this error with the Shell
projects that I've set up.  Then again I set a different project up as a
maven 2 project and ran a build without a problem.  This seems like a
bug in 1.0.3 to me.  I searched JIRA but wasn't able to find a similar
bug report.

Eric

-----Original Message-----
From: Jesse McConnell [mailto:jesse.mcconnell@gmail.com] 
Sent: Friday, August 24, 2007 9:18 AM
To: continuum-users@maven.apache.org
Subject: Re: Performance issues with multiple continuum instances on
single server

first part...is just kinda weird...

second part, do the builds have timeouts setup for them?

lastly, what were the problems you had with maven2 project setup?

jesse

On 8/21/07, Eric Roberts <Eric.Roberts@borland.com> wrote:
>
> Anyone have any suggestions?
>
> -----Original Message-----
> From: Eric Roberts [mailto:Eric.Roberts@borland.com]
> Sent: Thursday, August 16, 2007 12:00 PM
> To: continuum-users@maven.apache.org
> Subject: Performance issues with multiple continuum instances on 
> single server
>
> I am currently running 2 instances of continuum as windows services on

> a single Windows 2003 server (running as a VMware virtual machine).  
> The first instance was installed about 6 months ago and has run pretty
well.
> I just installed a second instance and have noticed a problem with its

> performance and availability.  When a build is running on the first 
> instance, this generally causes the second instance to become 
> unresponsive almost every time (i.e. I get a 404 not found message 
> when I try to access it in my browser).  The service will eventually 
> come back on its own after a few minutes but If I look in the 
> wrapper.log I see messages like the following
>
> ERROR  | wrapper  | 2007/08/09 09:27:50 | JVM appears hung: Timed out 
> waiting for signal from JVM.
> ERROR  | wrapper  | 2007/08/09 09:27:50 | JVM did not exit on request,

> terminated STATUS | wrapper  | 2007/08/09 09:27:55 | Launching a
JVM...
> INFO   | jvm 5    | 2007/08/09 09:27:57 | Wrapper (Version 3.1.2)
> http://wrapper.tanukisoftware.org
>
> Another issue that has been occurring on the second server is that 
> builds often run indefinitely.  It's almost as if the build process 
> has died somehow but continuum never noticed so the clock just keeps 
> ticking.  I am able to clean these builds up directly in the database 
> but I can't figure out why it keeps happening.
>
> A little background about the environment.  I have set up all projects

> in both continuum instances as shell projects but the builds 
> themselves use Maven 2.  We were unable to get the Maven 2.0 project 
> type to work correctly and the shell project type worked so we went 
> with it.  The maven build is executing some python scripts which are 
> used to process and transform XML documentation using XSLT (a little 
> convoluted I know but I inherited it).  The transformation is done 
> using the Java Saxon library which tends to require a lot of memory 
> and CPU.  I have a strong hunch that both of my issues are somehow 
> interrelated but am not sure where to start.
>
> Java 1.5.0_10
> Maven 2.0.4
> Python 2.4.1
> Saxon 6.5.5
> Windows 2003 server running as a VMWare virtual machine on Intel Xeon 
> 3GHz CPU w/ 3.75G RAM
>
> Any help or suggestions are greatly appreciated,
>
> Eric
>



--
jesse mcconnell
jesse.mcconnell@gmail.com

Mime
View raw message