continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kjartan Aanestad" <kjartan.aanes...@gmail.com>
Subject Re: Constantly getting build error..
Date Mon, 27 Aug 2007 06:43:30 GMT
yes, that seems to be the case.. When I get the build errors I log on to the
continuum console and force a new build and it builds successfully..

Anyone who knows what it could be related to?

On 24/08/07, Jesse McConnell <jesse.mcconnell@gmail.com> wrote:
>
> so only scheduled builds are effected in this way?
>
> On 8/24/07, Kjartan Aanestad <kjartan.aanestad@gmail.com> wrote:
> >
> > Hi,
> >
> > I'm constantly getting the following build error:
> >
> >
> >
> ****************************************************************************
> > Build Error:
> >
> >
> ****************************************************************************
> > org.codehaus.plexus.taskqueue.execution.TaskExecutionException: Error
> > executing action 'update-project-from-working-directory'
> >                 at
> >
> >
> org.apache.maven.continuum.buildcontroller.DefaultBuildController.performAction
> > (DefaultBuildController.java:432)
> >                 at
> > org.apache.maven.continuum.buildcontroller.DefaultBuildController.build(
> > DefaultBuildController.java:137)
> >                 at
> >
> >
> org.apache.maven.continuum.buildcontroller.BuildProjectTaskExecutor.executeTask
> > (BuildProjectTaskExecutor.java:50)
> >                 at
> >
> >
> org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run
> > (ThreadedTaskQueueExecutor.java:116)
> >                 at
> >
> >
> edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call
> > (Executors.java:442)
> >                 at
> > edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(
> > FutureTask.java:176)
> >                 at
> >
> >
> edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask
> > (ThreadPoolExecutor.java:665)
> >                 at
> >
> >
> edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run
> > (ThreadPoolExecutor.java:690)
> >                 at java.lang.Thread.run(Thread.java:595)
> > Caused by:
> > org.apache.maven.continuum.execution.ContinuumBuildExecutorException:
> > Error
> > while mapping metadata:add.project.artifact.not.found.error
> > add.project.unknown.error
> >
> >                 at
> >
> >
> org.apache.maven.continuum.execution.maven.m2.MavenTwoBuildExecutor.updateProjectFromCheckOut
> > (MavenTwoBuildExecutor.java:159)
> >
> >
> > I've been getting it on Continuum-1.1 alpha-1, alpha-2 og beta-2... If I
> > force a build in continuum it works fine though..
> >
> > Any suggestions? (Running maven-2.0.7 btw)
> >
> > -Kjartan
> >
>
>
>
> --
> jesse mcconnell
> jesse.mcconnell@gmail.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message