continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Otto Kolsi <o...@kolsi.fi>
Subject System time problem in Solaris 10 environment (Ant + Continuum)
Date Thu, 05 Jul 2007 11:04:20 GMT
Hi,

We are having strange problem with system time with Continuum in Solaris 
10 environment. Easiest way to verify existence of this problem is to 
add following block to Ant build script and let Continuum to 
build/execute it.
"<exec executable="/usr/bin/date"/>"

What happens is that 'date' reports GMT time and not the correct local 
time. This ONLY happens when Ant is executed through Continuum. If same 
Ant script is executed as a standalone it reports the corret time.

This problem causes times to differ three hours in ZIP-archives that are 
created using Ant's ZIP target. We've tried to enable full DEBUG logs 
with Continuum but only thing that's visible is this:
"...ShellCommandHelper             - Executing: 
/usr/local/apache-ant-1.7.0/bin/ant -f Build/continuum-build.xml build". 
 From that you cannot see what shell is in use or other details that 
might matter.

We've also added similar Ant exec calls to execute "set", "env" and "id" 
commands and tried to verify if e.g. TZ variable differs. But all the 
variables (LC_*, TZ) are same.

Any ideas how to solve this or how to find out where exactly the problem 
is? Our guess is that it's related to way Continuum executes Ant as a 
shell command.

  Otto

Mime
View raw message