continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anshula <anshula.b...@isobar.net>
Subject RE: Unable to sync from Perforce if Continuum is run as a service
Date Fri, 20 Jul 2007 13:56:27 GMT

I did try using Continuum 1.0.3 for the same project, and it does work as
John correctly pointed out. But the problem is that in our project
structure, we need to have project groups, and each group further has a
Maven2 project structure under it. Dont think version 1.0.3 will be very
useful for us.

Havent still been able to get it working. I tried will different accounts as
well, just doesnt work.
Also, today morning tried the 1.1-beta-1 version. Does not work with this
version as well.

Any other pointers...??

Thanks,
Anshula


Anshula wrote:
> 
> I did try both ways - 
> 1. using Local System account
> 2. by selecting the other option and changing the login to my account by
> supplying the user name and password so that the service runs under my
> account
> 
> It gives the same error either ways.
> What do you mean by environment variable / right differences ? My
> environment variables look fine, i guess the only one it looks for is
> MAVEN_HOME and JAVA_HOME, which is set in the System variables in my case.
> 
> Could it have something to do with perforce?
> Regards,
> Anshula
> 
> 
> John Coleman-6 wrote:
>> 
>> If your Windows service runs under a different profile, then maybe there
>> could be environment variables and rights differences?
>> 
>> I have Continuum 1.0.3 running fine as a service using Local System
>> Account.
>> 
>> John Coleman, MSTA
>> Senior Developer Consultant
>>  
>> Eurobase Banking Solutions 
>> Bury House, 31 Bury Street,
>> London EC3A 5AG, U.K.
>> 
>> Office:  +44 (0)1245 496 706, Fax: +44 (0)20 7626 6203
>> Mobile: +44 (0)7734 506586
>> 
>> -----Original Message-----
>> From: Anshula [mailto:anshula.bhat@isobar.net] 
>> Sent: 19 July 2007 14:51
>> To: continuum-users@maven.apache.org
>> Subject: Unable to sync from Perforce if Continuum is run as a service
>> 
>> 
>> Hi,
>> 
>> I have been trying to setup a build system using continuum for our
>> projects.
>> I have a Maven2 project(with modules) and the SCM is Perforce. 
>> 
>> Initially, I started continuum from the command line using the batch
>> file
>> "bin\windows-x86-32\run.bat". I was able to add the project successfully
>> from the UI and build it as well. 
>> 
>> After that I tried to setup Continuum as a service using the script
>> "bin\windows-x86-32\InstallService.bat". Again I tried to build the same
>> project again. But it refuses to build. Following is the part of error
>> trace
>> - 
>> 
>> ------------------------------------------------------------------------
>> -------------------
>> INFO   | jvm 1    | 2007/07/18 16:00:00 | 2007-07-18 16:00:00,333
>> [pool-1-thread-1] INFO  ScmManager:default             - Executing: p4
>> -d
>> C:\Try\project\254 -p hydrogen:1666 -u username client -i
>> INFO   | jvm 1    | 2007/07/18 16:00:00 | 2007-07-18 16:00:00,396
>> [pool-1-thread-1] WARN  ContinuumScm:default           - Error while
>> checking out the code for project: 'project-trial', id: '254' to
>> 'C:\Try\project\254'.
>> INFO   | jvm 1    | 2007/07/18 16:00:00 | 2007-07-18 16:00:00,396
>> [pool-1-thread-1] WARN  ContinuumScm:default           - Command output:
>> 
>> INFO   | jvm 1    | 2007/07/18 16:00:00 | 2007-07-18 16:00:00,396
>> [pool-1-thread-1] WARN  ContinuumScm:default           - Provider
>> message:
>> Unable to sync.  Are you logged in?
>> INFO   | jvm 1    | 2007/07/18 16:00:00 | 2007-07-18 16:00:00,396
>> [pool-1-thread-1] INFO  BuildController:default        - Merging SCM
>> results
>> INFO   | jvm 1    | 2007/07/18 16:00:00 | 2007-07-18 16:00:00,412
>> [pool-1-thread-1] INFO  BuildController:default        - Error updating
>> from
>> SCM, not building
>> ------------------------------------------------------------------------
>> -------------------
>> 
>> The version of Continuum that I am using is "continuum-1.1-alpha-2" and
>> the
>> maven version is 2.0.5.
>> 
>> 
>> Also, here is the SCM Section of my parent POM (if needed) -
>> ------------------------------------------------------------------------
>> -----------
>> <scm>	  
>> <connection>scm:perforce:username@scm-server:1666://Java-Development/pro
>> ject-trial</connection>	   	 
>> <developerConnection>scm:perforce:username@scm-server:1666://Java-Develo
>> pment/project-trial</developerConnection>   
>> </scm>
>> ......		
>> 	<build>
>> 	   <plugins>
>> 			<plugin>
>> 	
>> <groupId>org.apache.maven.plugins</groupId>
>> 			      <artifactId>maven-scm-plugin</artifactId>
>> 			      <version>1.0</version>
>> 			      <configuration>				
>> 	
>> <connectionType>developerConnection</connectionType>
>> 				 <username>username</username>
>> 				 <password>password</password>
>> 			      </configuration>
>> 			</plugin>
>> 	  </plugins>
>>        </build>
>> ------------------------------------------------------------------------
>> -----------
>> 
>> What possibly can be wrong? The same configration works fine while
>> Continuum
>> is in command line mode? 
>> 
>> Thanks,
>> Anshula
>> -- 
>> View this message in context:
>> http://www.nabble.com/Unable-to-sync-from-Perforce-if-Continuum-is-run-a
>> s-a-service-tf4111233.html#a11689772
>> Sent from the Continuum - Users mailing list archive at Nabble.com.
>> 
>> 
>> Eurobase International Limited and its subsidiaries (Eurobase) are unable
>> to exercise control over the content of information in E-Mails. Any views
>> and opinions expressed may be personal to the sender and are not
>> necessarily those of Eurobase. Eurobase will not enter into any
>> contractual obligations in respect of any part of its business in any
>> E-mail. 
>> 
>> Privileged / confidential information may be contained in this message
>> and /or any attachments. This E-mail is intended for the use of the
>> addressee(s) only and may contain confidential information. If you are
>> not the / an intended recipient, you are hereby notified that any use or
>> dissemination of this communication is strictly prohibited.  If you
>> receive this transmission in error, please notify us immediately, and
>> then delete this E-mail. 
>> 
>> Neither the sender nor Eurobase accepts any liability whatsoever for any
>> defects of any kind either in or arising from this E-mail transmission.
>> E-Mail transmission cannot be guaranteed to be secure or error-free, as
>> messages can be intercepted, lost, corrupted, destroyed, contain viruses,
>> or arrive late or incomplete. Eurobase does not accept any responsibility
>> for viruses and it is your responsibility to scan any attachments.
>> 
>> Eurobase Systems Limited is the main trading company in the Eurobase
>> International Group; registered in England and Wales as company number
>> 02251162; registered address: Essex House, 2 County Place, Chelmsford,
>> Essex CM2 0RE, UK.
>> 
>> 
>> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Unable-to-sync-from-Perforce-if-Continuum-is-run-as-a-service-tf4111233.html#a11708612
Sent from the Continuum - Users mailing list archive at Nabble.com.


Mime
View raw message