continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Meyer <michael.me...@netcetera.ch>
Subject [1.1-aplpha-2] Continuum ignores user and password information in scm url
Date Thu, 28 Jun 2007 10:00:37 GMT
Hi
I'm trying to add a maven2 project to continuum.
In the pom.xml file we have the following scm information:

<scm>
<connection>scm:cvs:pserver:builduser:secret@localhost:/cvs/project:Module</connection>
</scm>

After adding the project I get the following error message in the log:

2942581 [pool-2-thread-1] INFO 
org.apache.maven.scm.manager.ScmManager:default  - Executing: cvs -z3 -f 
-d :pserver:root@localhost:/cvs/project -q checkout -d 162 Module
2942581 [pool-2-thread-1] INFO 
org.apache.maven.scm.manager.ScmManager:default  - Working directory: 
/data/build/continuum-1.1-alpha-2/apps/continuum 
/webapp/WEB-INF/working-directory
2942697 [pool-2-thread-1] WARN 
org.apache.maven.continuum.scm.ContinuumScm:default  - Error while 
checking out the code for project: 'Project'
2942698 [pool-2-thread-1] WARN 
org.apache.maven.continuum.scm.ContinuumScm:default  - Command output:
2942698 [pool-2-thread-1] WARN 
org.apache.maven.continuum.scm.ContinuumScm:default  - Provider message: 
The cvs command failed.

Notice how builduser was replaced with root and the password got removed 
completely. On the other hand localhost, /cvs/project and Module have 
been read correctly.

Can I force continuum to use the complete url that I provide in the 
pom.xml file?

Cheers, michael



Mime
View raw message