continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "noban" <no...@yandex.ru>
Subject dir 'target/.svn' ... area is missing PROBLEM
Date Sat, 16 Jun 2007 12:12:04 GMT
Hi!

I'm new to maven, continuum and svn, therefore I have a problem integrating them. I've installed
coninuum 1.0.3 on Ubuntu7.04 box (actually problem arises on WinXP as well) as I've installed
svn client.  After that I can't setup a project in continuum. When I`m creating a new Maven2
project I point wizard to pom.xml file -> http://ann-research1.googlecode.com/svn/trunk/mvn-test1/pom.xml
which creates project (then I provide username/password): 

Project Name 	mvn-test1
Version 	1.0-SNAPSHOT
Scm Url 	scm:svn:http://ann-research1.googlecode.com/svn/trunk/
Scm Username 	xxxxxx
Scm Password 	xxxxxx
Scm Branch/Tag 	

First build results in warning - because of testngm but anyways project is builded, but all
later builds are ending with such output:

Provider message: The svn command failed.
Command output: 
-------------------------------------------------------------------------------
svn: Directory 'target/.svn' containing working copy admin area is missing
-------------------------------------------------------------------------------

I have no idea what to do and to check, here is my pom.xml file:

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
  <modelVersion>4.0.0</modelVersion>
  <groupId>mvn-test1</groupId>
  <artifactId>mvn-test1</artifactId>
  <version>1.0-SNAPSHOT</version>
  <packaging>jar</packaging>
  <name>mvn-test1</name>
  
  <ciManagement>
    <system>continuum</system>
    <url>http://localhost:9090/continuum</url>
  </ciManagement>
  
  <scm>
    <connection>scm:svn:http://ann-research1.googlecode.com/svn/trunk/</connection>
    <developerConnection>scm:svn:https://ann-research1.googlecode.com/svn/trunk/</developerConnection>
    <url>http://ann-research1.googlecode.com/svn/trunk/</url>
  </scm>
  
  <build>
    <plugins>
      <plugin>
        <artifactId>maven-compiler-plugin</artifactId>
        <version>2.0</version>
        <configuration>
          <source>1.5</source>
          <target>1.5</target>
        </configuration>
      </plugin>
    </plugins>
  </build>
  <dependencies>
    <dependency>
      <groupId>org.easymock</groupId>
      <artifactId>easymock</artifactId>
      <version>2.2</version>
    </dependency>
    <dependency>
      <groupId>org.testng</groupId>
      <artifactId>testng</artifactId>
      <version>5.5</version>
    </dependency>
    <dependency>
      <groupId>org.springframework</groupId>
      <artifactId>spring</artifactId>
      <version>2.0.2</version>
    </dependency>
    <dependency>
      <groupId>hibernate</groupId>
      <artifactId>hibernate</artifactId>
      <version>3.1rc2</version>
    </dependency>
    <dependency>
      <groupId>hsqldb</groupId>
      <artifactId>hsqldb</artifactId>
      <version>1.8.0.7</version>
    </dependency>
    
  </dependencies>
</project>


I use maven 2.0.6

Any ideas, tips?


Mime
View raw message