continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Stembridge <kevin.stembri...@db.com>
Subject Scheduled build definition won't run if no changes since other build def ran
Date Wed, 02 May 2007 08:08:53 GMT
Hi all,

I have multiple build definitions for a given project:

* mvn clean install - runs hourly during working hours
* mvn deploy - runs nightly
* mvn site-deploy - runs nightly

The problem is that a scheduled build definition won't run if its working 
copy is up-to-date with CVS, and all the build definitions share the same 
working copy. 
So I am often getting a situation where my nightly builds don't run 
because there have been no changes since the last hourly build, even 
though there have been plenty of changes since the last time the nightly 
build ran.

This issue looks like its the same problem:
http://jira.codehaus.org/browse/CONTINUUM-1226


Does anybody have any ideas on how to workaround this? For example, how 
can I specify a different working directory per build definition?

Cheers,
Kevin

---

This e-mail may contain confidential and/or privileged information. If you 
are not the intended recipient (or have received this e-mail in error) 
please notify the sender immediately and destroy this e-mail. Any 
unauthorized copying, disclosure or distribution of the material in this 
e-mail is strictly forbidden.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message