continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wayne Fay" <wayne...@gmail.com>
Subject Re: Schedule I've created isn't working
Date Mon, 02 Apr 2007 15:25:07 GMT
Perhaps Eric will reply with his specific curl command line... but in
the meantime.

http://curl.netmirror.org/docs/httpscripting.html
Go down to 4.2 POST.

Wayne

On 4/2/07, Chris Russell <chris.russell@oracle.com> wrote:
> Hi Eric,
>
> I actually like that idea - it solves some odd issues on my side.
> My question is what do I pass to Curl (I'd never heard of Curl until you
> mentioned it)?
>
> if my form definition looks like this:
>
> <form method="post" action="http://wd2013.us.oracle.com:8080/continuum/servlet/continuum">*
>
> and the Build All button looks like this:
>
> *<input type="submit" name="build-all" value="Build All"/>
>
> *What is the Curl command to get that done? (I looked thru the Curl FAQ - http://curl.netmirror.org/docs/faq.html
-
> but didn't see anything about hitting a button, although POST look suspicious).
>
> Thanks,
> Chris
> *
>
>
>
> Eric Pugh wrote:
> > Or, have a cron job call "Curl" and pass it in the URL of the "Build
> > Now" button for your project!  Hokey, but works.
> >
> > Eric
> >
> > On Mar 30, 2007, at 2:04 PM, Anoop kumar V wrote:
> >
> >> Continuum would only build if there was anything checked into your
> >> source
> >> control repository. If you are using Continuum 1.0.3 then there is no
> >> way to
> >> force a build even if there is no new code / changes to the VCS. Not
> >> sure if
> >> v1.1 has a way though.
> >>
> >> If that is indeed the case then you can use your build tool to basically
> >> commit a dummy file at the end of the build - so that the next time
> >> Continuum wakes up at the scheduled time, it will see the change and
> >> kick
> >> start a build.
> >>
> >> HTH,
> >> Anoop
> >>
> >> On 3/29/07, Chris Russell <chris.russell@oracle.com> wrote:
> >>>
> >>> Hello,
> >>>
> >>> I've gotten everything working in Continuum if I do a "Build All"
> >>> (tests
> >>> run, app is deployed....).
> >>>
> >>> My issue is that my build process is not running when I think it
> >>> should.
> >>> I'm using the DEFAULT_SCHEDULE, and the entry looks like this: 0 40
> >>> * * *
> >>> ?
> >>>
> >>> I thought that this would build my projects every hour at 40 min past
> >>> the hour (i.e. 09:40, 10:40...). Thats not what its doing. I even tried
> >>> restarting Continuum after I made the change (should I need to do
> >>> that?).
> >>>
> >>> I'm certain it something simple, but I'm just not seeing it.
> >>>
> >>> Any help is appreciated.
> >>>
> >>> Chris
> >>>
> >>
> >>
> >>
> >> --Thanks and best regards,
> >> Anoop
> >
> > -------------------------------------------------------
> > Principal
> > OpenSource Connections
> > Site: http://www.opensourceconnections.com
> > Blog: http://blog.opensourceconnections.com
> > Cell: 1-434-466-1467
> >
> >
> >
> >
> >
>

Mime
View raw message