continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mikko Wuokko <mikko.wuo...@evtek.fi>
Subject Re: Trouble with multi-module Maven2 project
Date Fri, 30 Mar 2007 06:30:37 GMT
Thanks again for your help, but I'm in need of your expertise again. 
What I would like happen would be that I would see all the modules as 
separate projects so that I would see which ones did or did not fail 
building. But I would like them also be under one working directory 
(those that are numbered like 1,2,3 etc..) instead of having 30 
different folders.

The faq entry over here
http://maven.apache.org/continuum/faqs.html#build-entire-project-recursively-from-parent

deescribes this situation pretty much, but what I have now is project 
folders running from 1-30 or so. Half of the stuff does not build as 
they are dependended on the parent poms and dont't find them as they 
will try to get from ../pom.xml where is only the numbered folder for 
other projects.

Do you have any suggestions on this..

-Mikko

Mikko Wuokko wrote:
> Thanks to both of you Emmanuel and Alistair.
> 
> Both ways, http and file, worked. Didn't realise it was the svn pom url 
> that I had to use and not the one from Maven repository.
> 
> -Mikko
> 
> Emmanuel Venisse wrote:
>>
>>
>> Mikko Wuokko a écrit :
>>> Thanks, but I didn't quite follow.. Where should I put the svn URL? 
>>> To the pom I upload to Continuum? Or should I use the svn URL to add 
>>> the project?
>>
>> http url on your svn when you add a project. If you don't have svn 
>> available with http, you can checkout your project on your server, 
>> activate the file protocol( see FAQs) and add your project with the 
>> file protocol.
>>
>> Emmanuel
>>
>>>
>>> I have added the SCM to the poms, and project is added nicely and the 
>>> sources are download from the svn if I remove the modules. With 
>>> modules it does what I described.
>>>
>>> -Mikko
>>>
>>> Emmanuel Venisse wrote:
>>>> Continuum try to download modules with an url created from the url 
>>>> you added. But your url is an url in a maven repository and modules 
>>>> aren't in a subdirectory.
>>>> You can provide a http url to your svn instead of maven repo.
>>>>
>>>> Emmanuel
>>>>
>>>> Mikko Wuokko a écrit :
>>>>> Hi.
>>>>>
>>>>> I'm trying to get our Maven2 project integrated into Continuum, but 
>>>>> so far haven't had luck.
>>>>>
>>>>> Simplified I got this kind of situation:
>>>>>
>>>>> 1 parent pom which has could of modules inside, like this
>>>>>
>>>>> Parent POM
>>>>>    |
>>>>>    |--ModuleA
>>>>>    |--ModuleB
>>>>>
>>>>> The files in the svn are like this
>>>>>
>>>>> Parent/
>>>>> Parent/ModuleA
>>>>> Parent/ModuleB
>>>>>
>>>>> When I try to upload the parent pom, it does find the modules, but 
>>>>> then it tries to download the pom.xml(!) for the modules and fails..
>>>>>
>>>>> The modules have parent reference to the parent pom all share the 
>>>>> same groupId.
>>>>>
>>>>> URL looks like these:
>>>>>
>>>>> The parent url is here
>>>>> http://myhost.com/maven2repo/org/mygoupid/myartefactid/version1.0/myartefactid-version1.0.pom

>>>>>
>>>>>
>>>>> The url for the modules pom.xml:
>>>>> http://myhost.com/maven2repo/org/mygoupid/myartefactid/version1.0/moduleArtefactId/pom.xml

>>>>>
>>>>>
>>>>> That of course does not exist.
>>>>>
>>>>> Can someone tell me if I have totally missed out something?
>>>>> Am I explaining this in the wrong way?
>>>>>
>>>>> Here also the some output from the continuum log:
>>>>>
>>>>> INFO   | jvm 1    | 2007/03/29 14:02:46 | 2007-03-29 14:02:46,597 
>>>>> [SocketListener0-1] INFO  Action:login                   -
>>>>> Trying to log in 'admin'.
>>>>> INFO   | jvm 1    | 2007/03/29 14:02:46 | username: admin
>>>>> INFO   | jvm 1    | 2007/03/29 14:02:53 | 2007-03-29 14:02:53,102 
>>>>> [SocketListener0-1] INFO  ContinuumProjectBuilder:maven-two
>>>>> -builder - Downloading 
>>>>> http://kplab.evtek.fi/maven2/org/kplab/kplab/1.0/kplab-1.0.pom
>>>>> INFO   | jvm 1    | 2007/03/29 14:02:53 | 2007-03-29 14:02:53,167 
>>>>> [SocketListener0-1] DEBUG PlexusContainer                -
>>>>> Profile with id: 'jetspeed-mysql' has been explicitly activated.
>>>>> INFO   | jvm 1    | 2007/03/29 14:02:53 | 2007-03-29 14:02:53,167 
>>>>> [SocketListener0-1] DEBUG PlexusContainer                -
>>>>> Profile with id: 'jetspeed-settings' has been explicitly activated.
>>>>> INFO   | jvm 1    | 2007/03/29 14:02:53 | 2007-03-29 14:02:53,220 
>>>>> [SocketListener0-1] DEBUG PlexusContainer                -
>>>>> Profile with id: 'jetspeed-mysql' has been explicitly activated.
>>>>> INFO   | jvm 1    | 2007/03/29 14:02:53 | 2007-03-29 14:02:53,220 
>>>>> [SocketListener0-1] DEBUG PlexusContainer                -
>>>>> Profile with id: 'jetspeed-settings' has been explicitly activated.
>>>>> INFO   | jvm 1    | 2007/03/29 14:02:53 | 2007-03-29 14:02:53,230 
>>>>> [SocketListener0-1] INFO  ContinuumProjectBuilder:maven-two
>>>>> -builder - Downloading 
>>>>> http://kplab.evtek.fi/maven2/org/kplab/kplab/1.0/kplab/ajaxcontroller/pom.xml

>>>>>
>>>>> INFO   | jvm 1    | 2007/03/29 14:02:53 | 2007-03-29 14:02:53,233 
>>>>> [SocketListener0-1] INFO  Continuum                      -
>>>>> Created 1 projects.
>>>>> INFO   | jvm 1    | 2007/03/29 14:02:53 | 2007-03-29 14:02:53,233 
>>>>> [SocketListener0-1] INFO  Continuum                      -
>>>>> Created 1 project groups.
>>>>> INFO   | jvm 1    | 2007/03/29 14:02:53 | 2007-03-29 14:02:53,233 
>>>>> [SocketListener0-1] INFO  Continuum                      -
>>>>> 1 warnings.
>>>>> INFO   | jvm 1    | 2007/03/29 14:02:53 | 2007-03-29 14:02:53,233 
>>>>> [SocketListener0-1] INFO  Continuum                      -
>>>>> Could not download 
>>>>> http://kplab.evtek.fi/maven2/org/kplab/kplab/1.0/kplab/ajaxcontroller/pom.xml:

>>>>> Unable to validate URL
>>>>>
>>>>>
>>>>> Thank you,
>>>>>
>>>>> Mikko Wuokko
>>>>>
>>>>>
>>>>>
>>>>
>>>
>>>
>>>
>>

Mime
View raw message