continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ulrich Metzger" <ulr...@muehlgasse.de>
Subject Re: SCM problems
Date Fri, 02 Feb 2007 07:52:14 GMT
Hi,
i had to solve the same problem.
To put the .cvspass file containing the cvs login information in the
homedirectory of the user running continuum solved the problem for me.

Uli

2007/2/2, Eric Rose <eric@forge.com.au>:
>
> Hi,
>
> I am trying to get continuum working to see if it will do a better job
> than
> our current cruisecontrol setup. The version of continuum I am using is
> 1.0.3
> and I cannot get a reliable build from it.
>
> The POM contains a SCM connection string like the following:
>
> scm:cvs:pserver:anonymous@cvsserver:2401/path/to/module
>
> which works fine for Maven.
>
> When I added the project and triggered a build, it failed with the error
> that
> a password was needed. According to the FAQ, the SCM URL should be changed
> to :anonymous:@cvsserver: so I did this and the build worked. So far so
> good...
>
> I then triggered another build and it failed again with the initial error.
> Going back to check the project info, I notice that the original SCM URL
> has
> replaced my modified version. Has anyone else seen, and hopefully found a
> reason for, this lacy of persistence of a project configuration?
>
> A second issue is that the port number in my URL causes problems, and I
> end up
> with messages in wrapper.log like the following:
>
> INFO   | jvm 1    | 2007/02/02 10:36:04 | 2007-02-02 10:36:04,122
> [Thread-2]
> DEBUG ScmManager                     -
> cvsRoot: :pserver:anonymous@cvsserver:24012401/path/to/module
>
> If I remove the port number from the configuration, I run into the first
> issue
> where the changes aren't persisted to further builds.
>
> Thanks for any pointers,
>
> Eric
>
> --
> Eric Rose              | "Sed quis custodiet ipsos custodes?"
> eric@integeo.com       |         Juvenal (Satires, VI.347-8)
>
> ***********************************************************************
> This message contains privileged and confidential information intended
> only for the use of the addressee named above.  If you are not the
> intended recipient of this message you must not disseminate, copy or
> take any action in reliance on it.  If you have received this message
> in error please notify the sender immediately.  Any views expressed in
> this message are those of the individual sender, except where the
> sender specifically states them to be the views of another (including
> a Body Corporate).
>
> If you wish to opt out from future messages, send an email to
> unsubscribe@integeo.com with the subject UNSUBSCRIBE
> ************************************************************************
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message