continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From joakim.zetterb...@ica.se
Subject Re: SCM problems
Date Fri, 02 Feb 2007 08:15:19 GMT
I'm not sure if this is the correct answer, but I had the same problem 
(although with SourceSafe), and as far as I could understand it, it was 
due to
the fact that when you trigger the build, you check out the source code, 
which includes the POM file.

Since the POM file in cvs contains the old scm url, it overwrites the one 
in the build definition, although I'm not really sure why. I almost went 
nuts over this until I
figured it out.

My solution was to modify the POM file, check it in, then either change 
the build definition or remove and add the project again.
It has worked flawless ever since.


Regards

Joakim Zetterberg



Eric Rose <eric@forge.com.au> wrote on 2007-02-02 01:06:07:

> Hi,
> 
> I am trying to get continuum working to see if it will do a better job 
than 
> our current cruisecontrol setup. The version of continuum I am usingis 
1.0.3 
> and I cannot get a reliable build from it.
> 
> The POM contains a SCM connection string like the following:
> 
> scm:cvs:pserver:anonymous@cvsserver:2401/path/to/module
> 
> which works fine for Maven.
> 
> When I added the project and triggered a build, it failed with the error 
that 
> a password was needed. According to the FAQ, the SCM URL should be 
changed 
> to :anonymous:@cvsserver: so I did this and the build worked. So far so 
> good...
> 
> I then triggered another build and it failed again with the initial 
error. 
> Going back to check the project info, I notice that the original SCM URL 
has 
> replaced my modified version. Has anyone else seen, and hopefully found 
a 
> reason for, this lacy of persistence of a project configuration?
> 
> A second issue is that the port number in my URL causes problems, 
> and I end up 
> with messages in wrapper.log like the following:
> 
> INFO   | jvm 1    | 2007/02/02 10:36:04 | 2007-02-02 10:36:04,122 
[Thread-2] 
> DEBUG ScmManager                     - 
> cvsRoot: :pserver:anonymous@cvsserver:24012401/path/to/module
> 
> If I remove the port number from the configuration, I run into the 
> first issue 
> where the changes aren't persisted to further builds.
> 
> Thanks for any pointers,
> 
> Eric
> 
> -- 
> Eric Rose              | "Sed quis custodiet ipsos custodes?"
> eric@integeo.com       |         Juvenal (Satires, VI.347-8)
> 
> ***********************************************************************
> This message contains privileged and confidential information intended
> only for the use of the addressee named above.  If you are not the
> intended recipient of this message you must not disseminate, copy or
> take any action in reliance on it.  If you have received this message
> in error please notify the sender immediately.  Any views expressed in
> this message are those of the individual sender, except where the
> sender specifically states them to be the views of another (including
> a Body Corporate).
> 
> If you wish to opt out from future messages, send an email to
> unsubscribe@integeo.com with the subject UNSUBSCRIBE
> ************************************************************************
> 
> [attachment "att0cowi.dat" deleted by Joakim 
> Zetterberg/H00JZG/HK_ITLOG/BORĂ…S/ICA/SE] 
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message