continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Minto van der Sluis <mi...@multimach.com>
Subject Setting up new project fails
Date Wed, 31 Jan 2007 08:48:56 GMT

Hi folks,

Setting up Continuum was pretty easy and all seems to work well until I
tried to add our first project to it. This project is just a parent pom so
nothing fancy, well almost nothing.

For SCM we are running CVS without anonymous access. To get this working in
the pom I included properties (is a profile activated by default) for
username and password in my settings.xml and use these in the pom. This
configuration looks something like this:

settings.xml:
	... snip ...
    <profile>
      <id>scm-credentials</id>

      <properties>
        <scm-username>${env.USERNAME}</scm-username>
        <scm-password>adam20064</scm-password>
      </properties>
    </profile>
	... snap ...

pom.xml
	... snip ...

    <scm>
     
<connection>scm:cvs:pserver:${scm-username}:@myserver:/cvs/myrepo:adam/base</connection>
     
<developerConnection>scm:cvs:pserver:${scm-username}:@myserver:/cvs/myrepo:adam/base</developerConnection>
    </scm>

	... 

        <plugin>
          <groupId>org.apache.maven.plugins</groupId>
          <artifactId>maven-scm-plugin</artifactId>
          <version>1.0-beta-3</version>
          <configuration>
          	<goals>install</goals>
          	<username>${scm-username}</username>
          	<password>${scm-password}</password>
          </configuration>
        </plugin>

	... snap ...

To check if this actually works I tried 'mvn scm.bootstrap' in a fresh
directory with just a pom and it works as expected. To make sure it will
work on Continuum I added the proper settings.xml to the buildserver.
Unfortunately this did not work. I checked JIRA and beleef issue 
http://jira.codehaus.org/browse/CONTINUUM-1049 CONTINUUM-1049  is what I am
experiencing. :-(

So I tried a different approach. Instead of uploading a pom I entered a url
to it. I used the scm:cvs notation for this, but whatever I try Continuum
has never been able to retrieve my pom. 

Seems like I am running out of options. Does anyone know how I can get my
projects into Continuum?

Kind regards,

Minto van der Sluis
-- 
View this message in context: http://www.nabble.com/Setting-up-new-project-fails-tf3147474.html#a8725270
Sent from the Continuum - Users mailing list archive at Nabble.com.


Mime
View raw message