continuum-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Georg Öttl" <georg.oe...@googlemail.com>
Subject Continuum classloader issues
Date Thu, 21 Dec 2006 13:27:07 GMT
Hi

I have a problem with a classloader and continuum. My build/tests work
perfectly with maven. But somehow, the pom.xml does not work in continuum.
Some tests fail due to classloader issues.

I tried to set the tests in maven to "fork", so that an own vm will be used
and played a bit with child delegeation. Anyhow when I run the build in
continuum I always get a failure. Probably there are some libraries missing

[snip]
java.lang.NoSuchMethodError:
org.eclipse.jdt.internal.compiler.env.NameEnvironmentAnswer
.<init>(Lorg/eclipse/jdt/internal/compiler/env/IBinaryType;)V
    at gate.util.compilers.Eclipse$1.findType(Eclipse.java:190)
    at gate.util.compilers.Eclipse$1.findType(Eclipse.java:157)
[snip]
Some jasper-jdt issues in Eclipse.java I guess. (
http://gate.ac.uk/releases/gate-3.1-build2270-ALL/doc/java2html/gate/util/compilers/Eclipse.java.htmlLine
190)

So, somehow the gate classloader gets confused. This does not happen with
maven only. Only maven+continuum confuses the classloader.

[snip]
[INFO] Surefire report directory: /home/goettl/continuum-1.0.3
/apps/continuum/working-directory/7/target/surefire-reports
Forking command line: java -Xmx900M -classpath
/home/goettl/.m2/repository/org/apache/maven/surefire/surefire-api/2.0/surefire-
api-2.0.jar:/home/goettl/.m2/repository/org/codehaus/plexus/plexus-utils/1.1/plexus-utils-1.1.jar:/home/goettl/.m2/repository/org/apache/maven/surefire/surefire-booter/2.0/surefire-booter-2.0.jar
org.apache.maven.surefire.booter.SurefireBooter /tmp/surefire3652tmp
/tmp/surefire3653tmp
[snip]

if anybody can help I'd be really thankful

best regards,
Georg

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message